summaryrefslogtreecommitdiff
path: root/app-doc/psmark/psmark-2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-doc/psmark/psmark-2.1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-doc/psmark/psmark-2.1.ebuild')
-rw-r--r--app-doc/psmark/psmark-2.1.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/app-doc/psmark/psmark-2.1.ebuild b/app-doc/psmark/psmark-2.1.ebuild
index e11fae44bd4d..eb216d2e1602 100644
--- a/app-doc/psmark/psmark-2.1.ebuild
+++ b/app-doc/psmark/psmark-2.1.ebuild
@@ -1,27 +1,26 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
MY_PN=${PN}-v
MY_P=${MY_PN}${PV}
-S=${WORKDIR}/${PN}
DESCRIPTION="Prints watermark-like text on any PostScript document"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
SRC_URI="http://www.antitachyon.com/download/${MY_P}.tar.gz"
+S="${WORKDIR}"/${PN}
-IUSE=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-string.patch\
- "${FILESDIR}"/${P}-Makefile-QA.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-string.patch
+ "${FILESDIR}"/${P}-Makefile-QA.patch
+)
src_compile() {
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"