summaryrefslogtreecommitdiff
path: root/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20220730.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-30 09:09:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-30 09:09:34 +0100
commitad0412d0cafb8c04ce98024155cf99a4cc27db44 (patch)
treec34688ab389c18775a322de6cd4cfd957cbe8014 /app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20220730.ebuild
parentcdb747b791914a30c287a3a8e33d1b635e431707 (diff)
gentoo auto-resync : 30:07:2022 - 09:09:33
Diffstat (limited to 'app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20220730.ebuild')
-rw-r--r--app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20220730.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20220730.ebuild b/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20220730.ebuild
new file mode 100644
index 000000000000..b17eee1c1d08
--- /dev/null
+++ b/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20220730.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Extension for nxml-mode with Gentoo-specific schemas"
+HOMEPAGE="https://gitweb.gentoo.org/proj/nxml-gentoo-schemas.git/"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="MIT GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+
+SITEFILE="60${PN}-gentoo.el"
+
+src_compile() { :; }
+
+src_install() {
+ insinto "${SITEETC}/${PN}"
+ doins schemas.xml *.rnc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}