summaryrefslogtreecommitdiff
path: root/app-leechcraft/lc-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /app-leechcraft/lc-core
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'app-leechcraft/lc-core')
-rw-r--r--app-leechcraft/lc-core/Manifest2
-rw-r--r--app-leechcraft/lc-core/lc-core-9999.ebuild44
2 files changed, 25 insertions, 21 deletions
diff --git a/app-leechcraft/lc-core/Manifest b/app-leechcraft/lc-core/Manifest
index b825008efc18..7a03f3689c72 100644
--- a/app-leechcraft/lc-core/Manifest
+++ b/app-leechcraft/lc-core/Manifest
@@ -1,2 +1,2 @@
-EBUILD lc-core-9999.ebuild 1185 BLAKE2B df633e13dfdff59a7932a079da5913b5d4c2b3d581cf7d83cf93c43c8e2b969a736f9f1eefc1ca2e6964e175a1cb258d285f283e21020a7ae9a1b0bdfaa9c920 SHA512 16d5a9a3a9daa3c106ccbc1cc22e20488e592e8a965caca694e204f403c83f0ea8208a5cb09ad35e1f37306ab6884b9cadcd03b5c8af49f0d8ff2f9d4cee8f47
+EBUILD lc-core-9999.ebuild 1140 BLAKE2B ed4ea38c74048697141b693d2bec5a0d8ff12f0a7627ebb7ba6880897aa221c3b5db45500fd663f26e62f9685b716a1ea8d9b1354d2f7b032995e78e0b9f8335 SHA512 27e88f96cc700fa8aa4c1bbf411f025ca8fb144193a3ba55c48665d346fdd039b0937372c403a8717abdc76243f76696cf06c6fa4e98bf4316c493649d87e043
MISC metadata.xml 633 BLAKE2B 62070ab45e1be6576733dedf35c3778a28876138617bab4868f0b8bae1df3b54921e278048e1b55b4e558194b21f9d82a8390a977d551ef5c3c7878f9bba4288 SHA512 45cc0f9aa42538cd9f9232e5981c9dbbc457e4dd89c9c82ab5dcfdb139df67d83149b6aafdaad4d04d03efda32b187c99605c30da5477a3de67eee9608a26e90
diff --git a/app-leechcraft/lc-core/lc-core-9999.ebuild b/app-leechcraft/lc-core/lc-core-9999.ebuild
index 8383dd36fa6c..1de10d566587 100644
--- a/app-leechcraft/lc-core/lc-core-9999.ebuild
+++ b/app-leechcraft/lc-core/lc-core-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
EGIT_REPO_URI="https://github.com/0xd34df00d/leechcraft.git"
@@ -11,47 +11,51 @@ DESCRIPTION="Core of LeechCraft, the modular network client"
SLOT="0"
KEYWORDS=""
-IUSE="debug doc +sqlite postgres +qwt"
+IUSE="debug doc postgres +qwt"
-COMMON_DEPEND=">=dev-libs/boost-1.62
+DEPEND="
+ dev-libs/boost:=
+ dev-qt/qtconcurrent:5
dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtxml:5
+ dev-qt/qtdbus:5
dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
dev-qt/qtscript:5
- dev-qt/qtsql:5[postgres?,sqlite?]
- dev-qt/qtdbus:5
+ dev-qt/qtsql:5
dev-qt/qtwebkit:5
- dev-qt/qtnetwork:5
dev-qt/qtwidgets:5
dev-qt/qtx11extras:5
- dev-qt/qtconcurrent:5
- dev-qt/linguist-tools:5
- qwt? ( x11-libs/qwt:6 )"
-DEPEND="${COMMON_DEPEND}
- doc? ( app-doc/doxygen )"
-RDEPEND="${COMMON_DEPEND}
+ dev-qt/qtxml:5
+ qwt? ( x11-libs/qwt:6 )
+"
+RDEPEND="${DEPEND}
+ dev-qt/qtsql:5[postgres?,sqlite]
dev-qt/qtsvg:5
|| (
kde-frameworks/oxygen-icons
x11-themes/kfaenza
- )"
-
-REQUIRED_USE="|| ( postgres sqlite )"
+ )
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ doc? ( app-doc/doxygen )
+"
src_configure() {
local mycmakeargs=(
-DWITH_PLUGINS=False
+ -DSKIP_MAN_COMPRESS=True
-DWITH_DOCS=$(usex doc)
-DWITH_QWT=$(usex qwt)
)
if [[ ${PV} != 9999 ]]; then
mycmakeargs+=( -DLEECHCRAFT_VERSION=${PV} )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
use doc && dodoc -r "${CMAKE_BUILD_DIR}/${PN#lc-}"/out/html/*
}