summaryrefslogtreecommitdiff
path: root/app-misc/dasel/dasel-1.27.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-19 01:57:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-19 01:57:29 +0100
commit84a400be40cf32d9e536ae34ebf14ad06ad6b8d6 (patch)
tree96ec24229ee5d9a7ed293011d39fa5a6438cab2d /app-misc/dasel/dasel-1.27.3.ebuild
parentd1262423b614597cd55d30370eb8de6bfa8f0899 (diff)
gentoo auto-resync : 19:10:2022 - 01:57:29
Diffstat (limited to 'app-misc/dasel/dasel-1.27.3.ebuild')
-rw-r--r--app-misc/dasel/dasel-1.27.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-misc/dasel/dasel-1.27.3.ebuild b/app-misc/dasel/dasel-1.27.3.ebuild
new file mode 100644
index 000000000000..261c64912713
--- /dev/null
+++ b/app-misc/dasel/dasel-1.27.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+
+DESCRIPTION="Query, update and convert data structures from the command line"
+HOMEPAGE="https://github.com/TomWright/dasel"
+SRC_URI="https://github.com/TomWright/dasel/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~zmedico/dist/dasel-1.24.3-deps.tar.xz"
+
+LICENSE="MIT Apache-2.0 BSD BSD-2 ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+src_compile() {
+ CGO_ENABLED=0 go build -o bin/dasel -ldflags="-X 'github.com/tomwright/dasel/internal.Version=${PV}'" ./cmd/dasel || die
+}
+
+src_install() {
+ dobin bin/dasel
+ dodoc CHANGELOG.md README.md
+}