summaryrefslogtreecommitdiff
path: root/app-portage/smart-live-rebuild/smart-live-rebuild-1.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /app-portage/smart-live-rebuild/smart-live-rebuild-1.4.0.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'app-portage/smart-live-rebuild/smart-live-rebuild-1.4.0.ebuild')
-rw-r--r--app-portage/smart-live-rebuild/smart-live-rebuild-1.4.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-portage/smart-live-rebuild/smart-live-rebuild-1.4.0.ebuild b/app-portage/smart-live-rebuild/smart-live-rebuild-1.4.0.ebuild
new file mode 100644
index 000000000000..70bc47266ae7
--- /dev/null
+++ b/app-portage/smart-live-rebuild/smart-live-rebuild-1.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Check live packages for updates and emerge them as necessary"
+HOMEPAGE="https://github.com/mgorny/smart-live-rebuild/"
+SRC_URI="https://github.com/mgorny/smart-live-rebuild/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~sparc ~x86 ~x64-macos"
+
+RDEPEND=">=app-portage/gentoopm-0.2.1[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /etc/portage
+ newins smart-live-rebuild.conf{.example,}
+ insinto /usr/share/portage/config/sets
+ newins sets.conf.example smart-live-rebuild.conf
+}