summaryrefslogtreecommitdiff
path: root/app-shells/powerline/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /app-shells/powerline/files
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'app-shells/powerline/files')
-rw-r--r--app-shells/powerline/files/2.7-ldflags.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/app-shells/powerline/files/2.7-ldflags.patch b/app-shells/powerline/files/2.7-ldflags.patch
new file mode 100644
index 000000000000..077c28af2a07
--- /dev/null
+++ b/app-shells/powerline/files/2.7-ldflags.patch
@@ -0,0 +1,15 @@
+diff -Naur powerline-status-2.7/setup.py powerline-status-2.7.new/setup.py
+--- powerline-status-2.7/setup.py 2018-08-12 14:41:44.000000000 -0500
++++ powerline-status-2.7.new/setup.py 2020-06-01 14:56:25.977968288 -0500
+@@ -30,9 +30,10 @@
+ from distutils.ccompiler import new_compiler
+ compiler = new_compiler().compiler
+ cflags = os.environ.get('CFLAGS', str('-O3'))
++ ldflags = os.environ.get('LDFLAGS', str(''))
+ # A normal split would do a split on each space which might be incorrect. The
+ # shlex will not split if a space occurs in an arguments value.
+- subprocess.check_call(compiler + shlex.split(cflags) + ['client/powerline.c', '-o', 'scripts/powerline'])
++ subprocess.check_call(compiler + shlex.split(cflags) + shlex.split(ldflags) + ['client/powerline.c', '-o', 'scripts/powerline'])
+
+ try:
+ compile_client()