summaryrefslogtreecommitdiff
path: root/app-text/lv/lv-4.51-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/lv/lv-4.51-r4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/lv/lv-4.51-r4.ebuild')
-rw-r--r--app-text/lv/lv-4.51-r4.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-text/lv/lv-4.51-r4.ebuild b/app-text/lv/lv-4.51-r4.ebuild
new file mode 100644
index 000000000000..a1b366d3665c
--- /dev/null
+++ b/app-text/lv/lv-4.51-r4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils toolchain-funcs
+
+MY_P="${PN}${PV//./}"
+
+DESCRIPTION="Powerful Multilingual File Viewer"
+HOMEPAGE="http://www.ff.iij4u.or.jp/~nrt/lv/"
+SRC_URI="http://www.ff.iij4u.or.jp/~nrt/freeware/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses:0=
+ !app-editors/levee"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=(README hello.sample)
+HTML_DOCS=(index.html relnote.html hello.sample.gif)
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-xz.diff
+ "${FILESDIR}"/${P}-tinfo.patch
+ "${FILESDIR}"/${P}-protos.patch
+)
+
+src_prepare() {
+ default
+
+ cd src
+ eautoreconf
+}
+
+src_configure() {
+ ECONF_SOURCE=src econf
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}