summaryrefslogtreecommitdiff
path: root/app-text/lv/lv-4.51-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/lv/lv-4.51-r4.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/lv/lv-4.51-r4.ebuild')
-rw-r--r--app-text/lv/lv-4.51-r4.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-text/lv/lv-4.51-r4.ebuild b/app-text/lv/lv-4.51-r4.ebuild
new file mode 100644
index 000000000000..2518014787f3
--- /dev/null
+++ b/app-text/lv/lv-4.51-r4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools toolchain-funcs
+
+MY_P="${PN}${PV//./}"
+
+DESCRIPTION="Powerful Multilingual File Viewer"
+#HOMEPAGE="http://www.ff.iij4u.or.jp/~nrt/lv/"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND="!app-editors/levee
+ sys-libs/ncurses:0="
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-gentoo.patch
+ "${FILESDIR}"/${PN}-headers.patch
+ "${FILESDIR}"/${PN}-tinfo.patch
+ "${FILESDIR}"/${PN}-xz.patch
+)
+DOCS=( README hello.sample )
+HTML_DOCS=( index.html relnote.html hello.sample.gif )
+
+src_prepare() {
+ default
+
+ cd src
+ mv configure.{in,ac}
+ eautoreconf
+}
+
+src_configure() {
+ ECONF_SOURCE=src econf
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}