summaryrefslogtreecommitdiff
path: root/app-vim/bnf-syntax/bnf-syntax-1.2-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-15 04:49:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-15 04:49:10 +0100
commitefca79f216bfeffd55e7731fbf24126d093e1084 (patch)
treef19ba31d8686b3de4192db3e4c4dc9f3d9af54b5 /app-vim/bnf-syntax/bnf-syntax-1.2-r3.ebuild
parentea7f3f690b55cdfa8b2d350b03c1dfc0c8357a51 (diff)
gentoo auto-resync : 15:09:2023 - 04:49:10
Diffstat (limited to 'app-vim/bnf-syntax/bnf-syntax-1.2-r3.ebuild')
-rw-r--r--app-vim/bnf-syntax/bnf-syntax-1.2-r3.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-vim/bnf-syntax/bnf-syntax-1.2-r3.ebuild b/app-vim/bnf-syntax/bnf-syntax-1.2-r3.ebuild
new file mode 100644
index 000000000000..8e08807acb05
--- /dev/null
+++ b/app-vim/bnf-syntax/bnf-syntax-1.2-r3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: BNF file syntax highlighting"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=250"
+
+LICENSE="vim.org"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides syntax highlighting for BNF files."
+
+src_prepare() {
+ default
+ # fix hi link to use def, bug #101790.
+ sed -i -e 's,hi link,hi def link,g' syntax/bnf.vim || die "sed failed"
+}