summaryrefslogtreecommitdiff
path: root/app-vim/fluxbox-syntax/fluxbox-syntax-1.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
commit79599515788b85b18aa655e7b7f8cc05c1bbddd8 (patch)
treeade7cb031f363fad64c77139dea7aa3d81908537 /app-vim/fluxbox-syntax/fluxbox-syntax-1.5-r1.ebuild
parent6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (diff)
gentoo resync : 16.02.1018
Diffstat (limited to 'app-vim/fluxbox-syntax/fluxbox-syntax-1.5-r1.ebuild')
-rw-r--r--app-vim/fluxbox-syntax/fluxbox-syntax-1.5-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-vim/fluxbox-syntax/fluxbox-syntax-1.5-r1.ebuild b/app-vim/fluxbox-syntax/fluxbox-syntax-1.5-r1.ebuild
new file mode 100644
index 000000000000..1165be5cb0ab
--- /dev/null
+++ b/app-vim/fluxbox-syntax/fluxbox-syntax-1.5-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: fluxbox files syntax and indent"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=679"
+LICENSE="vim"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+
+RDEPEND="app-vim/genindent"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides syntax highlighting and indent settings for fluxbox
+menus and similar files. Upstream don't provide us with an ftdetect file,
+but a simple one has been created for you by this ebuild. You can manually
+set the filetype using :set filetype=fluxbox if necessary."
+
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ mkdir ftdetect || die
+ echo "au BufNewFile,BufRead /*/*fluxbox/*menu set filetype=fluxbox" \
+ > ftdetect/fluxbox.vim || die
+}