summaryrefslogtreecommitdiff
path: root/dev-cpp/aixlog
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-31 12:01:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-31 12:01:05 +0100
commit5b7f6475da27c05b30659a00ecb49636aca2bece (patch)
treef67500afbab4acebaa18739efa57f79c7ee620b3 /dev-cpp/aixlog
parent2e8abb8c82f14dd064991a1afd337b2f022b37f6 (diff)
gentoo auto-resync : 31:08:2024 - 12:01:05
Diffstat (limited to 'dev-cpp/aixlog')
-rw-r--r--dev-cpp/aixlog/Manifest2
-rw-r--r--dev-cpp/aixlog/aixlog-1.5.0-r1.ebuild (renamed from dev-cpp/aixlog/aixlog-9999.ebuild)16
2 files changed, 5 insertions, 13 deletions
diff --git a/dev-cpp/aixlog/Manifest b/dev-cpp/aixlog/Manifest
index e754da46c71a..b04741d3c830 100644
--- a/dev-cpp/aixlog/Manifest
+++ b/dev-cpp/aixlog/Manifest
@@ -1,4 +1,4 @@
DIST aixlog-1.5.0.tar.gz 14080 BLAKE2B 20042e44853da950cae80787e8b9692635f0935ff0b559054faaf6ac41db4de7ddef1ab071b4244f1338b81fa559ee9445aa643050f9e250587cbbc0aae5db3e SHA512 28556feac1fa804b8a4dc047471e0a6d4c4fb7d81487810d55b09dd1be878246b8bf9f2097b76a980284318823c287bd0a93dd7a3124425a1ea9aced757152b6
+EBUILD aixlog-1.5.0-r1.ebuild 455 BLAKE2B 3239da3d8fb6d6c51f09c433b47a99eb871a6bf0541c598aa1ae39839c4250d61657503fbf004632fa7cd479d1ba50ee82cf79b22955b4beb6965495ee377064 SHA512 3b1971cf3bf9a01692982514d3fbafff53770f92404e1194c406d5633143e49e2733ff6822acd8f6e4e26c15d49d7855ce2ca5e6bb98f1bb2d98cd434ec78033
EBUILD aixlog-1.5.0.ebuild 587 BLAKE2B a1f4879e4ddf07933170d631d725c29b3dc9ea651d36e011a2f4b77536b70778a26eb350ca791f1d9f49b8ed92b4bda40f0fed7ce27e68464019346671ca4d53 SHA512 7302b12e29866ec8d17cc584c6eda822678417ff51e8d018453859dd7de1901b34e10d275d2c73f3a367c97c4d945e46e7cb8e5fbdd1a9970f808586c5fece59
-EBUILD aixlog-9999.ebuild 567 BLAKE2B a0d0e1552b3b35d1eaa8193df63a259a512871631a5e7c6968f73099684acf87aac57d09302af6ad33ebe833998633c4ed2bcd9dfb1317c5b8fa6e4f3f53a58f SHA512 a4eef4b0a89f2bfb97ba52585e6f6e262560466a49a872c86e6968f9920c4a3861c89aba7d1a706059ceb506f3bb6ae38aac9d1eca96c988b39083ddaada19d3
MISC metadata.xml 499 BLAKE2B 7dea962d454843ca3cde921a8dd30fadcb75f163f8ccf16a51b0d3de5176e8f6cae4788271f9924d5edd79e3e7b4ebe118e55f7397b8b5a8a8d1ec03d2a44241 SHA512 20dbf828621fdc1a4379192ed16d3f1e37bb8c5fe9974638f0b8e7c330d007133a589f5e8d23560d19de3c7c5eaa52c2d1e98d61be9326a998376a45c8f866b2
diff --git a/dev-cpp/aixlog/aixlog-9999.ebuild b/dev-cpp/aixlog/aixlog-1.5.0-r1.ebuild
index b1164d6bbd11..4bac816603bb 100644
--- a/dev-cpp/aixlog/aixlog-9999.ebuild
+++ b/dev-cpp/aixlog/aixlog-1.5.0-r1.ebuild
@@ -1,25 +1,17 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake
DESCRIPTION="Header-only C++ logging library"
HOMEPAGE="https://github.com/badaix/aixlog"
-
-if [[ ${PV} == *9999 ]] ; then
- inherit git-r3
-
- EGIT_REPO_URI="https://github.com/badaix/aixlog.git"
- EGIT_BRANCH="develop"
-else
- SRC_URI="https://github.com/badaix/aixlog/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
+SRC_URI="https://github.com/badaix/aixlog/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~x86"
src_configure() {
local mycmakeargs=( -DBUILD_EXAMPLE=OFF )