summaryrefslogtreecommitdiff
path: root/dev-cpp/catch/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-cpp/catch/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-cpp/catch/files')
-rw-r--r--dev-cpp/catch/files/catch-2.2.2-python-automagic.patch25
-rw-r--r--dev-cpp/catch/files/catch-2.2.2-test-python3.patch44
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-cpp/catch/files/catch-2.2.2-python-automagic.patch b/dev-cpp/catch/files/catch-2.2.2-python-automagic.patch
new file mode 100644
index 000000000000..ecc99905d7f0
--- /dev/null
+++ b/dev-cpp/catch/files/catch-2.2.2-python-automagic.patch
@@ -0,0 +1,25 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -308,6 +308,9 @@
+
+ include(CTest)
+
++# Approval tests require python 2.7 or 3
++find_package(PythonInterp)
++
+ if (BUILD_TESTING AND NOT_SUBPROJECT)
+ add_executable(SelfTest ${TEST_SOURCES} ${IMPL_SOURCES} ${REPORTER_SOURCES} ${SURROGATE_SOURCES} ${HEADERS})
+ target_include_directories(SelfTest PRIVATE ${HEADER_DIR})
+@@ -384,7 +387,11 @@
+ set_tests_properties(NoTest PROPERTIES PASS_REGULAR_EXPRESSION "No test cases matched")
+
+ # AppVeyor has a Python 2.7 in path, but doesn't have .py files as autorunnable
+- add_test(NAME ApprovalTests COMMAND python ${CMAKE_CURRENT_SOURCE_DIR}/scripts/approvalTests.py $<TARGET_FILE:SelfTest>)
++ if(NOT ${PYTHONINTERP_FOUND})
++ message(FATAL_ERROR "Python not found, but required for running tests!")
++ endif()
++
++ add_test(NAME ApprovalTests COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/scripts/approvalTests.py $<TARGET_FILE:SelfTest>)
+ set_tests_properties(ApprovalTests PROPERTIES FAIL_REGULAR_EXPRESSION "Results differed")
+
+ if (CATCH_USE_VALGRIND)
diff --git a/dev-cpp/catch/files/catch-2.2.2-test-python3.patch b/dev-cpp/catch/files/catch-2.2.2-test-python3.patch
new file mode 100644
index 000000000000..0712f1577077
--- /dev/null
+++ b/dev-cpp/catch/files/catch-2.2.2-test-python3.patch
@@ -0,0 +1,44 @@
+From dc6b83bec9bdcc149db08711cc9dfd555a8620fa Mon Sep 17 00:00:00 2001
+From: Tom Hughes <tom@compton.nu>
+Date: Fri, 6 Apr 2018 13:59:08 +0100
+Subject: [PATCH] Support Python3 in approval tests
+
+---
+ scripts/approvalTests.py | 15 +++++++++++----
+ 1 file changed, 11 insertions(+), 4 deletions(-)
+
+diff --git a/scripts/approvalTests.py b/scripts/approvalTests.py
+index a2ab5d5a2..16cc7b7d2 100755
+--- a/scripts/approvalTests.py
++++ b/scripts/approvalTests.py
+@@ -72,10 +72,17 @@
+
+ overallResult = 0
+
++def openFile(file, mode):
++ try:
++ return open(file, mode, encoding='utf-8', errors='surrogateescape')
++ except TypeError:
++ import io
++ return io.open(file, mode, encoding='utf-8', errors='surrogateescape')
++
+ def diffFiles(fileA, fileB):
+- with open(fileA, 'r') as file:
++ with openFile(fileA, 'r') as file:
+ aLines = [line.rstrip() for line in file.readlines()]
+- with open(fileB, 'r') as file:
++ with openFile(fileB, 'r') as file:
+ bLines = [line.rstrip() for line in file.readlines()]
+
+ shortenedFilenameA = fileA.rsplit(os.sep, 1)[-1]
+@@ -139,8 +146,8 @@ def approve(baseName, args):
+ subprocess.call(args, stdout=f, stderr=f)
+ f.close()
+
+- rawFile = open(rawResultsPath, 'r')
+- filteredFile = open(filteredResultsPath, 'w')
++ rawFile = openFile(rawResultsPath, 'r')
++ filteredFile = openFile(filteredResultsPath, 'w')
+ for line in rawFile:
+ filteredFile.write(filterLine(line).rstrip() + "\n")
+ filteredFile.close()