summaryrefslogtreecommitdiff
path: root/dev-haskell/libyaml/libyaml-0.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/libyaml/libyaml-0.1.2.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/libyaml/libyaml-0.1.2.ebuild')
-rw-r--r--dev-haskell/libyaml/libyaml-0.1.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/libyaml/libyaml-0.1.2.ebuild b/dev-haskell/libyaml/libyaml-0.1.2.ebuild
new file mode 100644
index 000000000000..be4c94e648a6
--- /dev/null
+++ b/dev-haskell/libyaml/libyaml-0.1.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Low-level, streaming YAML interface"
+HOMEPAGE="https://github.com/snoyberg/yaml#readme"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="no-unicode system-libyaml"
+
+RDEPEND=">=dev-haskell/conduit-1.2.8:=[profile?] <dev-haskell/conduit-1.4:=[profile?]
+ >=dev-haskell/resourcet-0.3:=[profile?] <dev-haskell/resourcet-1.3:=[profile?]
+ >=dev-lang/ghc-8.0.2:=
+ system-libyaml? ( dev-libs/libyaml )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.2.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag no-unicode no-unicode) \
+ $(cabal_flag system-libyaml system-libyaml)
+}