summaryrefslogtreecommitdiff
path: root/dev-libs/libical/libical-3.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-libs/libical/libical-3.0.5.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-libs/libical/libical-3.0.5.ebuild')
-rw-r--r--dev-libs/libical/libical-3.0.5.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/dev-libs/libical/libical-3.0.5.ebuild b/dev-libs/libical/libical-3.0.5.ebuild
index 8db90e5024fb..b977742f2cd4 100644
--- a/dev-libs/libical/libical-3.0.5.ebuild
+++ b/dev-libs/libical/libical-3.0.5.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{5,6,7} )
-inherit cmake-utils python-any-r1
+PYTHON_COMPAT=( python3_{6,7} )
+inherit cmake python-any-r1
DESCRIPTION="An implementation of basic iCAL protocols"
HOMEPAGE="https://github.com/libical/libical"
@@ -52,7 +52,7 @@ pkg_setup() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
use examples || cmake_comment_add_subdirectory examples
}
@@ -61,18 +61,18 @@ src_configure() {
-DICAL_GLIB=$(usex glib)
-DICAL_GLIB_VAPI=OFF
-DGOBJECT_INTROSPECTION=OFF
- $(cmake-utils_use_find_package berkdb BDB)
+ $(cmake_use_find_package berkdb BDB)
-DICAL_BUILD_DOCS=$(usex doc)
-DSHARED_ONLY=$(usex !static-libs)
)
# TODO: disabled until useful
# -DGOBJECT_INTROSPECTION=$(usex introspection)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
- use doc && cmake-utils_src_compile docs
+ cmake_src_compile
+ use doc && cmake_src_compile docs
}
src_test() {
@@ -80,13 +80,13 @@ src_test() {
-E "(icalrecurtest|icalrecurtest-r)" # bug 660282
)
- cmake-utils_src_test
+ cmake_src_test
}
src_install() {
use doc && HTML_DOCS=( "${BUILD_DIR}"/apidocs/html/. )
- cmake-utils_src_install
+ cmake_src_install
if use examples; then
rm examples/CMakeLists.txt || die