summaryrefslogtreecommitdiff
path: root/dev-libs/libthreadar/libthreadar-1.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-libs/libthreadar/libthreadar-1.4.0.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-libs/libthreadar/libthreadar-1.4.0.ebuild')
-rw-r--r--dev-libs/libthreadar/libthreadar-1.4.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/libthreadar/libthreadar-1.4.0.ebuild b/dev-libs/libthreadar/libthreadar-1.4.0.ebuild
new file mode 100644
index 000000000000..7ad10216fc22
--- /dev/null
+++ b/dev-libs/libthreadar/libthreadar-1.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Threading library used by dar archiver"
+HOMEPAGE="https://sourceforge.net/projects/libthreadar/"
+SRC_URI="mirror://sourceforge/libthreadar/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+src_prepare() {
+ default
+
+ # this is an example binary that is not installed
+ # the original Makefile tries to compile it statically,
+ # no longer supported
+ sed -i -e '/^test_barrier_LDFLAGS/d' doc/examples/Makefile.am || die
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdatadir="${EPREFIX}"/usr/share/doc/${PF}/html install
+
+ einstalldocs
+
+ find "${ED}" -name '*.la' -delete || die
+}