summaryrefslogtreecommitdiff
path: root/dev-libs/pegtl/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-libs/pegtl/files
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-libs/pegtl/files')
-rw-r--r--dev-libs/pegtl/files/pegtl-2.8.3-cmake.patch29
-rw-r--r--dev-libs/pegtl/files/pegtl-2.8.3-gcc-10.patch43
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-libs/pegtl/files/pegtl-2.8.3-cmake.patch b/dev-libs/pegtl/files/pegtl-2.8.3-cmake.patch
new file mode 100644
index 000000000000..140e1f5cfbb8
--- /dev/null
+++ b/dev-libs/pegtl/files/pegtl-2.8.3-cmake.patch
@@ -0,0 +1,29 @@
+--- a/CMakeLists.txt 2020-04-22 19:43:00.000000000 +0200
++++ b/CMakeLists.txt 2020-12-27 00:00:15.886046938 +0100
+@@ -78,4 +78,3 @@
+
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/pegtl-config-version.cmake DESTINATION ${PEGTL_INSTALL_CMAKE_DIR})
+ install(DIRECTORY include/ DESTINATION ${PEGTL_INSTALL_INCLUDE_DIR})
+-install(FILES LICENSE DESTINATION ${PEGTL_INSTALL_DOC_DIR})
+--- a/src/test/pegtl/CMakeLists.txt 2020-04-22 19:43:00.000000000 +0200
++++ b/src/test/pegtl/CMakeLists.txt 2020-12-27 00:07:19.122766830 +0100
+@@ -123,7 +123,7 @@
+ if(MSVC)
+ target_compile_options(${exename} PRIVATE /W4 /WX /utf-8)
+ else()
+- target_compile_options(${exename} PRIVATE -pedantic -Wall -Wextra -Wshadow -Werror)
++ target_compile_options(${exename} PRIVATE -pedantic -Wall -Wextra -Wshadow)
+ endif()
+ if(ANDROID)
+ add_test(NAME ${exename} WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/../../.. COMMAND ${CMAKE_COMMAND} -DANDROID_NDK=${ANDROID_NDK} "-DTEST_RESOURCES=src/test/pegtl/data;src/test/pegtl/file_data.txt;Makefile" -DTEST_RESOURCES_DIR=${CMAKE_CURRENT_SOURCE_DIR}/../../.. -DUNITTEST=${CMAKE_CURRENT_BINARY_DIR}/${exename} -DTEST_PARAMETER=-all -P ${CMAKE_CURRENT_SOURCE_DIR}/ExecuteOnAndroid.cmake)
+--- a/src/example/pegtl/CMakeLists.txt 2020-04-22 19:43:00.000000000 +0200
++++ b/src/example/pegtl/CMakeLists.txt 2020-12-27 00:07:32.970832890 +0100
+@@ -48,7 +48,7 @@
+ if(MSVC)
+ target_compile_options(${exename} PRIVATE /W4 /WX /utf-8)
+ else()
+- target_compile_options(${exename} PRIVATE -pedantic -Wall -Wextra -Wshadow -Werror)
++ target_compile_options(${exename} PRIVATE -pedantic -Wall -Wextra -Wshadow)
+ endif()
+ endforeach(examplesourcefile)
+
diff --git a/dev-libs/pegtl/files/pegtl-2.8.3-gcc-10.patch b/dev-libs/pegtl/files/pegtl-2.8.3-gcc-10.patch
new file mode 100644
index 000000000000..ef418e44254e
--- /dev/null
+++ b/dev-libs/pegtl/files/pegtl-2.8.3-gcc-10.patch
@@ -0,0 +1,43 @@
+From a3a292c2ba66bf09b4adc4cee8fcdfb1b1386067 Mon Sep 17 00:00:00 2001
+From: Daniel Frey <d.frey@gmx.de>
+Date: Mon, 11 May 2020 22:19:31 +0200
+Subject: [PATCH] Repair warning from GCC 10
+
+* Backported patch thx to Fedora.
+
+---
+ include/tao/pegtl/contrib/rep_one_min_max.hpp | 21 +++++++++++++++++++
+ 1 file changed, 21 insertions(+)
+
+diff --git a/include/tao/pegtl/contrib/rep_one_min_max.hpp b/include/tao/pegtl/contrib/rep_one_min_max.hpp
+index 7ec4639e..ee0a3782 100644
+--- a/include/tao/pegtl/contrib/rep_one_min_max.hpp
++++ b/include/tao/pegtl/contrib/rep_one_min_max.hpp
+@@ -45,6 +45,27 @@ namespace tao
+ }
+ };
+
++ template< unsigned Max, char C >
++ struct rep_one_min_max< 0, Max, C >
++ {
++ using analyze_t = analysis::counted< analysis::rule_type::any, 0 >;
++
++ template< typename Input >
++ static bool match( Input& in )
++ {
++ const auto size = in.size( Max + 1 );
++ std::size_t i = 0;
++ while( ( i < size ) && ( in.peek_char( i ) == C ) ) {
++ ++i;
++ }
++ if( i <= Max ) {
++ bump_help< result_on_found::success, Input, char, C >( in, i );
++ return true;
++ }
++ return false;
++ }
++ };
++
+ template< unsigned Min, unsigned Max, char C >
+ inline constexpr bool enable_control< rep_one_min_max< Min, Max, C > > = false;
+