summaryrefslogtreecommitdiff
path: root/dev-libs/pegtl/pegtl-3.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
commit391b5b359a346aff490103da7dddc85047f83830 (patch)
tree29eea460a0bd7e1ff21d43b9d6df9af4d8a175e1 /dev-libs/pegtl/pegtl-3.2.1.ebuild
parentc719fdcee603a5a706a45d10cb598762d56a727d (diff)
gentoo resync : 01.10.2021
Diffstat (limited to 'dev-libs/pegtl/pegtl-3.2.1.ebuild')
-rw-r--r--dev-libs/pegtl/pegtl-3.2.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/pegtl/pegtl-3.2.1.ebuild b/dev-libs/pegtl/pegtl-3.2.1.ebuild
new file mode 100644
index 000000000000..09fd47749d97
--- /dev/null
+++ b/dev-libs/pegtl/pegtl-3.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Header-only library for creating parsers according to Parsing Expression Grammar"
+HOMEPAGE="https://github.com/taocpp/PEGTL"
+SRC_URI="https://github.com/taocpp/PEGTL/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P^^}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-werror.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DPEGTL_INSTALL_CMAKE_DIR="$(get_libdir)/cmake/${PN}"
+ -DPEGTL_INSTALL_DOC_DIR="share/doc/${PF}"
+ )
+ cmake_src_configure
+}