summaryrefslogtreecommitdiff
path: root/dev-php/symfony-dependency-injection/symfony-dependency-injection-2.8.50.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
commit121ed4eec41fbf03e1998d09eede1bf449da63b9 (patch)
treece9341d77d1507f67d4a3a1472da9011b5baa0a8 /dev-php/symfony-dependency-injection/symfony-dependency-injection-2.8.50.ebuild
parentdd762ff83c330186ee2ede002e08b2f780cddd51 (diff)
gentoo resync : 19.07.2019
Diffstat (limited to 'dev-php/symfony-dependency-injection/symfony-dependency-injection-2.8.50.ebuild')
-rw-r--r--dev-php/symfony-dependency-injection/symfony-dependency-injection-2.8.50.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-php/symfony-dependency-injection/symfony-dependency-injection-2.8.50.ebuild b/dev-php/symfony-dependency-injection/symfony-dependency-injection-2.8.50.ebuild
new file mode 100644
index 000000000000..e1ab01ad6686
--- /dev/null
+++ b/dev-php/symfony-dependency-injection/symfony-dependency-injection-2.8.50.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Symfony DependencyInjection Component"
+HOMEPAGE="https://github.com/symfony/dependency-injection"
+SRC_URI="https://github.com/symfony/dependency-injection/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# The test suite requires the unpackaged symfony-expression-language.
+RESTRICT=test
+
+# I'm not sure if symfony-config and symfony-yaml are actually needed if
+# you're not running the test suite...
+RDEPEND="dev-lang/php:*
+ dev-php/fedora-autoloader
+ >=dev-php/symfony-config-2.1.0
+ >=dev-php/symfony-yaml-2.1.0"
+DEPEND="test? ( ${RDEPEND} >=dev-php/phpunit-5.7.15 )"
+
+S="${WORKDIR}/dependency-injection-${PV}"
+
+src_prepare() {
+ default
+ if use test; then
+ cp "${FILESDIR}/autoload.php" "${S}/autoload-test.php" || die
+ fi
+}
+
+src_install() {
+ insinto "/usr/share/php/Symfony/Component/DependencyInjection"
+ doins -r Compiler Dumper Exception Extension LazyProxy Loader ParameterBag
+ doins *.php "${FILESDIR}/autoload.php"
+ dodoc CHANGELOG.md README.md
+}
+
+src_test() {
+ phpunit --bootstrap "${S}/autoload-test.php" || die 'test suite failed'
+}