summaryrefslogtreecommitdiff
path: root/dev-python/3to2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/3to2
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/3to2')
-rw-r--r--dev-python/3to2/3to2-1.1.1-r1.ebuild34
-rw-r--r--dev-python/3to2/3to2-1.1.1.ebuild24
-rw-r--r--dev-python/3to2/Manifest4
-rw-r--r--dev-python/3to2/metadata.xml15
4 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/3to2/3to2-1.1.1-r1.ebuild b/dev-python/3to2/3to2-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..ed9d46062026
--- /dev/null
+++ b/dev-python/3to2/3to2-1.1.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Tool to refactor valid 3.x syntax into valid 2.x syntax"
+HOMEPAGE="https://pypi.org/project/3to2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+
+python_prepare() {
+ # https://bitbucket.org/amentajo/lib3to2/issues/50/testsuite-fails-with-new-python-35
+ # Remove failing test
+ sed -i -e "/test_argument_unpacking/a \\ return"\
+ lib3to2/tests/test_print.py || die
+ sed -i -e "s/Exception, err/Exception as err/" lib3to2/build.py || die
+ distutils-r1_python_prepare_all
+
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ # the standard test runner fails to properly return failure
+ "${PYTHON}" -m unittest discover || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/3to2/3to2-1.1.1.ebuild b/dev-python/3to2/3to2-1.1.1.ebuild
new file mode 100644
index 000000000000..8a18fe04f319
--- /dev/null
+++ b/dev-python/3to2/3to2-1.1.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit distutils-r1
+
+DESCRIPTION="Tool to refactor valid 3.x syntax into valid 2.x syntax"
+HOMEPAGE="https://pypi.org/project/3to2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ # the standard test runner fails to properly return failure
+ "${PYTHON}" -m unittest discover || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/3to2/Manifest b/dev-python/3to2/Manifest
new file mode 100644
index 000000000000..f95ba6833e11
--- /dev/null
+++ b/dev-python/3to2/Manifest
@@ -0,0 +1,4 @@
+DIST 3to2-1.1.1.zip 78779 BLAKE2B 441e74bd06017c84bd382c32513d84f42b8bc35f46aeb62ec1e3f5b9876573e0a76f6e04f4ca529175761af6f29e10ee0c4d4114ff0bcafb066d2d6344b1d885 SHA512 7580f174409420556f89ae78eba07cc95b95aee9d062586d0862bd41980ae31bf4ac82a43855e160eec745fcdd3b4aff614f68e77da1bfc5f9f404413cab1492
+EBUILD 3to2-1.1.1-r1.ebuild 939 BLAKE2B 67d6cc7d6cac0f0ddf937c9847bf99834b46f56ac2d2cfba113dacba72e4fff93875c2c7fe8648de297d81b8da630d9bb042ab932ca8831ff82132a03897fcbe SHA512 1b967222a40b03d34fd7ffc242a98bed96e1a515757f86b07fa55793e58e18cd847f7fc6873464d6dee1c91ae82e248cc178c5e0a455b7e077b8ef3ac70423b9
+EBUILD 3to2-1.1.1.ebuild 602 BLAKE2B 1dfaba6b53e68c27309f2155bcc0ef79835b4c0e089037e859351b18afabf369914d0024518133cfdcb55512bafc4ba48bd23b91570be403f37c0466b761da56 SHA512 6525223b64993403cd4c6880cb5d62dd17e2ed5f5e83e237560e480e9bd6e043e18d570d0752a506efc51b33f55364e0c94c523fff8bde738d36b7ac0a4aed28
+MISC metadata.xml 433 BLAKE2B 4f1b66cebd6b0b9f083d0896f702cc2f882d0d05a28634fad2d83af9802ccdfeb237e8d1eddee71c5a18663ede779085c28c81c3586b4ccfa2274c5dd8a9e1cc SHA512 fbf01ed6fe0bfdf49ba985e62e8694d7152129e0d46a3701fe39dd11ed7d48641efaea848694a271f39b9ae7e6b805b0ac535945cf33d455e0745d1f66ad3c04
diff --git a/dev-python/3to2/metadata.xml b/dev-python/3to2/metadata.xml
new file mode 100644
index 000000000000..57a9d13fae65
--- /dev/null
+++ b/dev-python/3to2/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">3to2</remote-id>
+ </upstream>
+</pkgmetadata>