summaryrefslogtreecommitdiff
path: root/dev-python/brotlipy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/brotlipy
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/brotlipy')
-rw-r--r--dev-python/brotlipy/Manifest4
-rw-r--r--dev-python/brotlipy/brotlipy-0.7.0.ebuild48
-rw-r--r--dev-python/brotlipy/metadata.xml12
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/brotlipy/Manifest b/dev-python/brotlipy/Manifest
new file mode 100644
index 000000000000..cc51e566abf1
--- /dev/null
+++ b/dev-python/brotlipy/Manifest
@@ -0,0 +1,4 @@
+DIST brotli-46c1a881b41bb638c76247558aa04b1591af3aa7.tar.gz 19840371 BLAKE2B b9a1c3c2e5b62bd63b392debe54bd1732ac1cb31f88500f0142108b453649d96901d9a03b6db98642cb9abaf9188c06d440f2b8bd3cf57fbbb52196a931f5079 SHA512 dc573c90491032a205f32f0ce9c93e95b06c70a3107caa9501e038a212226c37117d63709a29843367344bf7d18cf32d0c0578b11166387198e12b38b1522406
+DIST brotlipy-0.7.0.tar.gz 19375 BLAKE2B 035dc8757e491bc4fc0d8e2b6b82703eecc8f6f4150da42fda0f6c6f42a617519f5191371eb1dd976b8bbfeab88845bb018b874a395cdbf0ff409a6911f969f5 SHA512 bec8183cf3cc8ba9e594d1a86a8a33d88a6ac8e9c6a6287c837bda3726183ff1b486f2c49da4e489b5b3cb51b57dd5816413b59419920c2ced48435221f1beaf
+EBUILD brotlipy-0.7.0.ebuild 1394 BLAKE2B 8c8c1a33cd9fd421b148e1e2e5923fcce622a45a7a597b626152724c0fed1f559741f185c83b6fadd89f01c2c1de207b7d0bd4938d292f19668f13c2224fe909 SHA512 858947542d0b6879dc438184ab8e50c6dda037264b9cd2f9bba7c642edfb7b2f274f1b8f56cae9930eaeee01ec7735aca8075c64b6daff74c6a5d10352b62b79
+MISC metadata.xml 381 BLAKE2B 0ce0f75aab60659850e7d04532911feea89a4bccf8ec7826ebfb924416af438d5a2bf7981435a22e825b39881ac20a8b2a0bd93a66b2d7b031c72123033f1d78 SHA512 9b3a37c75a62f1873288ffba45ab105225a90d72e01c7ead253b5a903ec28babe152074cc7595d6398104f8ccc50ebfc71ff72c4e620a7dad1b5e57f767cd118
diff --git a/dev-python/brotlipy/brotlipy-0.7.0.ebuild b/dev-python/brotlipy/brotlipy-0.7.0.ebuild
new file mode 100644
index 000000000000..8d08a0abeedf
--- /dev/null
+++ b/dev-python/brotlipy/brotlipy-0.7.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+# Commit of the Brotli library bundled within brotlipy.
+BROTLI_BUNDLED_COMMIT="46c1a881b41bb638c76247558aa04b1591af3aa7"
+
+DESCRIPTION="Python binding to the Brotli library"
+HOMEPAGE="https://github.com/python-hyper/brotlipy/ https://pypi.python.org/pypi/brotlipy"
+SRC_URI="
+ https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/google/brotli/archive/${BROTLI_BUNDLED_COMMIT}.tar.gz -> brotli-${BROTLI_BUNDLED_COMMIT}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="virtual/python-cffi[${PYTHON_USEDEP}]"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ # Inject the brotli lib.
+ rm -r "${WORKDIR}/${P}/libbrotli" || die "Could not remove the bundled brotli lib folder."
+ cp -r "${WORKDIR}/brotli-${BROTLI_BUNDLED_COMMIT}/" "${WORKDIR}/${P}/libbrotli" || die "Could not inject the brotli lib."
+
+ # Tests fail if we have this folder preserved within the lib.
+ rm -r "${WORKDIR}/${P}/libbrotli/python" || die "Could not remove 'python' subfolder."
+
+ eapply_user
+}
+
+python_test() {
+ py.test -v || die "Testing failed"
+}
diff --git a/dev-python/brotlipy/metadata.xml b/dev-python/brotlipy/metadata.xml
new file mode 100644
index 000000000000..e7214b7e32c5
--- /dev/null
+++ b/dev-python/brotlipy/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>oleksandr.trotsenko@gmail.com</email>
+ <name>Oleksandr Trotsenko</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>