summaryrefslogtreecommitdiff
path: root/dev-python/cookies/cookies-2.2.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/cookies/cookies-2.2.1-r2.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/cookies/cookies-2.2.1-r2.ebuild')
-rw-r--r--dev-python/cookies/cookies-2.2.1-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/cookies/cookies-2.2.1-r2.ebuild b/dev-python/cookies/cookies-2.2.1-r2.ebuild
new file mode 100644
index 000000000000..e3378cf99352
--- /dev/null
+++ b/dev-python/cookies/cookies-2.2.1-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Friendlier RFC 6265-compliant cookie parser/renderer"
+HOMEPAGE="https://gitlab.com/sashahart/cookies"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+
+PATCHES=(
+ # https://gitlab.com/sashahart/cookies/merge_requests/2
+ "${FILESDIR}/cookies-2.2.1-fix-warnings.patch"
+
+ "${FILESDIR}/cookies-2.2.1-tests.patch"
+)
+
+distutils_enable_tests pytest