summaryrefslogtreecommitdiff
path: root/dev-python/python-recaptcha/python-recaptcha-2.0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /dev-python/python-recaptcha/python-recaptcha-2.0.1-r1.ebuild
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'dev-python/python-recaptcha/python-recaptcha-2.0.1-r1.ebuild')
-rw-r--r--dev-python/python-recaptcha/python-recaptcha-2.0.1-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/python-recaptcha/python-recaptcha-2.0.1-r1.ebuild b/dev-python/python-recaptcha/python-recaptcha-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..ab63a2563b07
--- /dev/null
+++ b/dev-python/python-recaptcha/python-recaptcha-2.0.1-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A plugin for reCAPTCHA and reCAPTCHA Mailhide"
+HOMEPAGE="https://github.com/redhat-infosec/python-recaptcha"
+SRC_URI="https://github.com/redhat-infosec/python-recaptcha/releases/download/v${PV}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="|| ( dev-python/pycryptodome[${PYTHON_USEDEP}] dev-python/pycrypto[${PYTHON_USEDEP}] )
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ !dev-python/recaptcha-client"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"