summaryrefslogtreecommitdiff
path: root/dev-python/rq/rq-1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
commit121ed4eec41fbf03e1998d09eede1bf449da63b9 (patch)
treece9341d77d1507f67d4a3a1472da9011b5baa0a8 /dev-python/rq/rq-1.0.ebuild
parentdd762ff83c330186ee2ede002e08b2f780cddd51 (diff)
gentoo resync : 19.07.2019
Diffstat (limited to 'dev-python/rq/rq-1.0.ebuild')
-rw-r--r--dev-python/rq/rq-1.0.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/rq/rq-1.0.ebuild b/dev-python/rq/rq-1.0.ebuild
new file mode 100644
index 000000000000..41b1969f2d48
--- /dev/null
+++ b/dev-python/rq/rq-1.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="simple, lightweight library for creating and processing background jobs"
+HOMEPAGE="https://github.com/rq/rq"
+SRC_URI="mirror://pypi/${PN:0:1}"/${PN}/${P}.tar.gz
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=" >=dev-python/click-5.0[${PYTHON_USEDEP}]
+ >=dev-python/redis-py-3.0.0[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"