summaryrefslogtreecommitdiff
path: root/dev-python/semantic_version/semantic_version-2.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/semantic_version/semantic_version-2.10.0.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/semantic_version/semantic_version-2.10.0.ebuild')
-rw-r--r--dev-python/semantic_version/semantic_version-2.10.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/semantic_version/semantic_version-2.10.0.ebuild b/dev-python/semantic_version/semantic_version-2.10.0.ebuild
new file mode 100644
index 000000000000..c0c7120df32d
--- /dev/null
+++ b/dev-python/semantic_version/semantic_version-2.10.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library providing a few tools handling SemVer in Python"
+HOMEPAGE="
+ https://github.com/rbarrois/python-semanticversion/
+ https://pypi.org/project/semantic-version/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv ~s390 ~sparc x86"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p no:django
+}