summaryrefslogtreecommitdiff
path: root/dev-python/tqdm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/tqdm
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/tqdm')
-rw-r--r--dev-python/tqdm/Manifest4
-rw-r--r--dev-python/tqdm/metadata.xml19
-rw-r--r--dev-python/tqdm/tqdm-4.23.3.ebuild30
-rw-r--r--dev-python/tqdm/tqdm-9999.ebuild21
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
new file mode 100644
index 000000000000..66dba7f09237
--- /dev/null
+++ b/dev-python/tqdm/Manifest
@@ -0,0 +1,4 @@
+DIST tqdm-4.23.3.tar.gz 75941 BLAKE2B 9e5810765e8f7ea4f54b0f93f453d278d5ad4b1710f1476a6f00ff2e513789585e97dcd5a8331fe69d3593b18affd50bf9bf51cbaed29ecd68d4efad9318aa31 SHA512 40c853b7cf7611ba2ef7652417c0d42ea4392f5ea9cbe319dbb9e3dd063594e5c637fb5d13f77935fb9a034d395b28fa9480fec1c6cca1852644add4ac18cce8
+EBUILD tqdm-4.23.3.ebuild 684 BLAKE2B a5f96e68a62784f95bdc4eab911a6e661b208be290c8751461f6af9a8329fcae06c2a79737ec36ebf6740821f7835809274ffc25e32bf0ecec0c158cccdf3cc2 SHA512 267e493f2adb47092266a7682c6bd5ae52a344cddfe2186dcfe863339f7a9b998bb7ca2cea664af3264f3f9bb35957705f211188be83371ca5054362f08cf1d1
+EBUILD tqdm-9999.ebuild 451 BLAKE2B 0e1886badc6483aac49a80b38bc48aca750d65162987b2ba592d5e26478ad884cd4c7d59844d4289e3ca17896ac358d2214159d7042df170a7f269838c068946 SHA512 e167d21e90b11b03571c432d56686cd08cb95e0f976dd9b2a5b8012c4cc2474fbfa5f673f2db8794d46a25ea75a300e7c88d12bd201c4f03c19889c887fd9d92
+MISC metadata.xml 611 BLAKE2B 508436ed86075ea93acdfda799c34f6b05b38ed48c77e5673cbb11d1b424be1a0b98be584ecdf4544848ffd0061dcab39d24bb67d2d0ef631d295d8f91d02cd5 SHA512 62ef0673bcb397648689769eac6e735f5de8a3df69d41e63a04b2e9b79cef3fea64c2183ab9bc83827dd7d1e1f982b0decb17ebaee96bbf4928bd9a545fac29c
diff --git a/dev-python/tqdm/metadata.xml b/dev-python/tqdm/metadata.xml
new file mode 100644
index 000000000000..39c0d0d24421
--- /dev/null
+++ b/dev-python/tqdm/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>horea.christ@gmail.com</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ Instantly make your loops show a progress meter - just wrap
+ any iterator with "tqdm(iterator)", and you're done!
+ </longdescription>
+ <upstream>
+ <remote-id type="github">tqdm/tqdm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/tqdm/tqdm-4.23.3.ebuild b/dev-python/tqdm/tqdm-4.23.3.ebuild
new file mode 100644
index 000000000000..3fc8e3c7b495
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.23.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="https://github.com/tqdm/tqdm"
+SRC_URI="https://github.com/tqdm/tqdm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e "s#man/man1#share/man/man1#" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/tqdm/tqdm-9999.ebuild b/dev-python/tqdm/tqdm-9999.ebuild
new file mode 100644
index 000000000000..259f431eeb7b
--- /dev/null
+++ b/dev-python/tqdm/tqdm-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Add a progress meter to your loops in a second."
+HOMEPAGE="https://github.com/tqdm/tqdm"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/tqdm/tqdm"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""