summaryrefslogtreecommitdiff
path: root/dev-python/wand/wand-0.6.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-17 08:31:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-17 08:31:06 +0100
commitb99d693f4d27fe2eb2237a0fe7e9c3b87d4d6df5 (patch)
tree6ff0b08fefeec2ae1d739e566814553b80b9d685 /dev-python/wand/wand-0.6.8.ebuild
parenta6266c63b23ed0ee16865627ca53e4f5353f0a5c (diff)
gentoo auto-resync : 17:07:2022 - 08:31:06
Diffstat (limited to 'dev-python/wand/wand-0.6.8.ebuild')
-rw-r--r--dev-python/wand/wand-0.6.8.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/wand/wand-0.6.8.ebuild b/dev-python/wand/wand-0.6.8.ebuild
new file mode 100644
index 000000000000..753e731d2674
--- /dev/null
+++ b/dev-python/wand/wand-0.6.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=${P^}
+DESCRIPTION="Ctypes-based simple ImageMagick binding for Python"
+HOMEPAGE="
+ https://docs.wand-py.org/
+ https://github.com/emcconville/wand/
+ https://pypi.org/project/Wand/
+"
+SRC_URI="mirror://pypi/${MY_P::1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-gfx/imagemagick
+"
+BDEPEND="
+ test? (
+ media-gfx/imagemagick[fftw,jpeg,png,truetype,xml]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_test() {
+ # PDF support is blocked by the default ImageMagick security policy
+ epytest --skip-pdf
+}