summaryrefslogtreecommitdiff
path: root/dev-qt/qtbluetooth/qtbluetooth-5.15.10-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-01 22:14:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-01 22:14:42 +0100
commit9bc60dddf90169c365a03537991b4d9a5d9b28db (patch)
tree2f2cae7cd5d44dcfd43dc1a4fc81665fba314e8f /dev-qt/qtbluetooth/qtbluetooth-5.15.10-r1.ebuild
parentaef01e7679692cb2cf9eca0c03865cfd0a4e33c9 (diff)
gentoo auto-resync : 01:09:2023 - 22:14:42
Diffstat (limited to 'dev-qt/qtbluetooth/qtbluetooth-5.15.10-r1.ebuild')
-rw-r--r--dev-qt/qtbluetooth/qtbluetooth-5.15.10-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-qt/qtbluetooth/qtbluetooth-5.15.10-r1.ebuild b/dev-qt/qtbluetooth/qtbluetooth-5.15.10-r1.ebuild
new file mode 100644
index 000000000000..4f1c6bc59be1
--- /dev/null
+++ b/dev-qt/qtbluetooth/qtbluetooth-5.15.10-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ QT5_KDEPATCHSET_REV=2
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+QT5_MODULE="qtconnectivity"
+inherit qt5-build
+
+DESCRIPTION="Bluetooth support library for the Qt5 framework"
+
+IUSE="qml"
+
+DEPEND="
+ =dev-qt/qtconcurrent-${QT5_PV}*
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ =dev-qt/qtdbus-${QT5_PV}*
+ =dev-qt/qtnetwork-${QT5_PV}*
+ >=net-wireless/bluez-5:=
+ qml? ( =dev-qt/qtdeclarative-${QT5_PV}* )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e 's/nfc//' src/src.pro || die
+
+ qt_use_disable_mod qml quick src/src.pro
+
+ qt5-build_src_prepare
+}