summaryrefslogtreecommitdiff
path: root/dev-ruby/http-accept/http-accept-2.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-03 13:53:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-03 13:53:01 +0100
commit4b4d352fc9761396c68812d8eccc63b7b14d6558 (patch)
tree4f290d635d831599222130ba8ddbf1a726129426 /dev-ruby/http-accept/http-accept-2.2.0.ebuild
parenta2c1a301b2ea85c230b30ef69ff667f230a1bf88 (diff)
gentoo auto-resync : 03.08.2022 - 13:42:43
Diffstat (limited to 'dev-ruby/http-accept/http-accept-2.2.0.ebuild')
-rw-r--r--dev-ruby/http-accept/http-accept-2.2.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/http-accept/http-accept-2.2.0.ebuild b/dev-ruby/http-accept/http-accept-2.2.0.ebuild
new file mode 100644
index 000000000000..4cfb7baa55fc
--- /dev/null
+++ b/dev-ruby/http-accept/http-accept-2.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="http-accept.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Parse Accept and Accept-Language HTTP headers"
+HOMEPAGE="https://github.com/socketry/http-accept"
+SRC_URI="https://github.com/socketry/http-accept/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/covered/ s:^:#:' spec/spec_helper.rb || die
+ sed -e 's:_relative ": "./:' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}