summaryrefslogtreecommitdiff
path: root/dev-scheme/owl-lisp/owl-lisp-0.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-01 14:22:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-01 14:22:04 +0000
commitad1d34add08caaf8d68c79e40f0a61c733fd68b8 (patch)
tree032c16fc1d6e2bcee85eb7e16e378692090a4d05 /dev-scheme/owl-lisp/owl-lisp-0.2.1.ebuild
parent1581db777aa413144ae9aaff70602eae670c8b93 (diff)
gentoo auto-resync : 01:01:2023 - 14:22:03
Diffstat (limited to 'dev-scheme/owl-lisp/owl-lisp-0.2.1.ebuild')
-rw-r--r--dev-scheme/owl-lisp/owl-lisp-0.2.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-scheme/owl-lisp/owl-lisp-0.2.1.ebuild b/dev-scheme/owl-lisp/owl-lisp-0.2.1.ebuild
new file mode 100644
index 000000000000..9a3d4efc4581
--- /dev/null
+++ b/dev-scheme/owl-lisp/owl-lisp-0.2.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NOTICE: Because it is "purely functional" it is not scheme-compatible ootb
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Purely functional dialect of Scheme"
+HOMEPAGE="https://haltp.org/posts/owl.html"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/owl-lisp/owl.git"
+else
+ SRC_URI="https://gitlab.com/owl-lisp/owl/-/archive/v${PV}/owl-v${PV}.tar.bz2"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/owl-v${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_prepare() {
+ default
+
+ sed -i 's|make bin/vm|$(MAKE) bin/vm|g' "${S}"/Makefile || die
+}
+
+src_compile(){
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" owl
+}
+
+src_install() {
+ einstalldocs
+
+ dobin "${S}"/bin/ol
+ newbin "${S}"/bin/vm ovm
+ doman "${S}"/doc/*.1
+}