summaryrefslogtreecommitdiff
path: root/dev-tcltk/tcllib/tcllib-1.20.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /dev-tcltk/tcllib/tcllib-1.20.ebuild
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'dev-tcltk/tcllib/tcllib-1.20.ebuild')
-rw-r--r--dev-tcltk/tcllib/tcllib-1.20.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-tcltk/tcllib/tcllib-1.20.ebuild b/dev-tcltk/tcllib/tcllib-1.20.ebuild
new file mode 100644
index 000000000000..54cb1d43047c
--- /dev/null
+++ b/dev-tcltk/tcllib/tcllib-1.20.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit virtualx
+
+DESCRIPTION="Tcl Standard Library"
+HOMEPAGE="http://www.tcl.tk/software/tcllib/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="examples"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-lang/tcl:0=
+ dev-tcltk/tdom
+ "
+DEPEND="${RDEPEND}"
+
+DOCS=(
+ ChangeLog DESCRIPTION.txt README.md devdoc/README.developer
+ devdoc/critcl-tcllib.txt devdoc/dirlayout_install.txt
+ devdoc/indexing.txt
+)
+HTML_DOCS=( idoc/www )
+
+PATCHES=( "${FILESDIR}"/${P}-test.patch )
+
+src_test() {
+ USER= virtx emake test_batch
+}
+
+src_install() {
+ default
+
+ if use examples ; then
+ for f in $(find examples -type f); do
+ docinto $(dirname $f)
+ dodoc $f
+ done
+ fi
+}