summaryrefslogtreecommitdiff
path: root/dev-util/babeltrace/babeltrace-1.2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/babeltrace/babeltrace-1.2.3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/babeltrace/babeltrace-1.2.3.ebuild')
-rw-r--r--dev-util/babeltrace/babeltrace-1.2.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/babeltrace/babeltrace-1.2.3.ebuild b/dev-util/babeltrace/babeltrace-1.2.3.ebuild
new file mode 100644
index 000000000000..6fe8e9289c0e
--- /dev/null
+++ b/dev-util/babeltrace/babeltrace-1.2.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A command-line tool and library to read and convert trace files"
+HOMEPAGE="http://lttng.org"
+SRC_URI="http://lttng.org/files/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/popt
+ sys-apps/util-linux
+ "
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ "
+src_configure() {
+ econf $(use_enable test glibtest)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}