summaryrefslogtreecommitdiff
path: root/dev-util/byacc/byacc-20240109.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-14 07:13:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-14 07:13:52 +0000
commitfe1e3bbca60a6b4b9a1889f5252e02c27b459f63 (patch)
tree2ee0c8c664dc7593daf17a1bfac31e1dd4e5c6f5 /dev-util/byacc/byacc-20240109.ebuild
parent94eb99943eafb48140b436b347abaaee77209c01 (diff)
gentoo auto-resync : 14:01:2024 - 07:13:52
Diffstat (limited to 'dev-util/byacc/byacc-20240109.ebuild')
-rw-r--r--dev-util/byacc/byacc-20240109.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/byacc/byacc-20240109.ebuild b/dev-util/byacc/byacc-20240109.ebuild
new file mode 100644
index 000000000000..4c5f0bd32c90
--- /dev/null
+++ b/dev-util/byacc/byacc-20240109.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/thomasdickey.asc
+inherit verify-sig
+
+DESCRIPTION="The best variant of the Yacc parser generator"
+HOMEPAGE="https://invisible-island.net/byacc/byacc.html"
+SRC_URI="https://invisible-island.net/archives/${PN}/${P}.tgz"
+SRC_URI+=" verify-sig? ( https://invisible-island.net/archives/${PN}/${P}.tgz.asc )"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris"
+
+BDEPEND="verify-sig? ( >=sec-keys/openpgp-keys-thomasdickey-20240114 )"
+
+DOCS=( ACKNOWLEDGEMENTS AUTHORS CHANGES NEW_FEATURES NOTES README )
+
+src_configure() {
+ econf \
+ --program-prefix=b \
+ --with-manpage-format=formatted
+}