summaryrefslogtreecommitdiff
path: root/dev-util/lttng-ust/lttng-ust-2.10.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /dev-util/lttng-ust/lttng-ust-2.10.6.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'dev-util/lttng-ust/lttng-ust-2.10.6.ebuild')
-rw-r--r--dev-util/lttng-ust/lttng-ust-2.10.6.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/lttng-ust/lttng-ust-2.10.6.ebuild b/dev-util/lttng-ust/lttng-ust-2.10.6.ebuild
new file mode 100644
index 000000000000..ead5c2518d16
--- /dev/null
+++ b/dev-util/lttng-ust/lttng-ust-2.10.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P="${P/_rc/-rc}"
+MY_SLOT="$(ver_cut 1-2)"
+
+DESCRIPTION="Linux Trace Toolkit - UST library"
+HOMEPAGE="http://lttng.org"
+SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${MY_SLOT}"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-libs/userspace-rcu:="
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ default
+ if ! use examples; then
+ sed -i -e '/SUBDIRS/s:examples::' doc/Makefile.am || die
+ fi
+ eautoreconf
+}
+
+src_configure() {
+ econf --docdir=/usr/share/doc/${PF}
+}