summaryrefslogtreecommitdiff
path: root/dev-util/min-cscope/min-cscope-16.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/min-cscope/min-cscope-16.1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/min-cscope/min-cscope-16.1.0.ebuild')
-rw-r--r--dev-util/min-cscope/min-cscope-16.1.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/min-cscope/min-cscope-16.1.0.ebuild b/dev-util/min-cscope/min-cscope-16.1.0.ebuild
new file mode 100644
index 000000000000..a32340f19d04
--- /dev/null
+++ b/dev-util/min-cscope/min-cscope-16.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit cmake-utils flag-o-matic
+
+DESCRIPTION="Interactively examine a C program"
+HOMEPAGE="https://sourceforge.net/projects/kscope/"
+SRC_URI="mirror://sourceforge/kscope/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+S=${WORKDIR}/${PN}
+
+DOCS="AUTHORS README* TODO"
+
+src_prepare() {
+ echo 'INSTALL(TARGETS min-cscope RUNTIME DESTINATION bin)' \
+ >> src/CMakeLists.txt
+}
+
+src_configure() {
+ append-flags -I"${S}/sort"
+ cmake-utils_src_configure
+}