summaryrefslogtreecommitdiff
path: root/dev-util/sasm/sasm-2.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
commit80208fb578cf92cc308906660ca6d7860c6b2a1f (patch)
tree6f06818031b553c506fc10dfe9908a835df288aa /dev-util/sasm/sasm-2.2-r1.ebuild
parent06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (diff)
gentoo resync : 09.03.2018
Diffstat (limited to 'dev-util/sasm/sasm-2.2-r1.ebuild')
-rw-r--r--dev-util/sasm/sasm-2.2-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/sasm/sasm-2.2-r1.ebuild b/dev-util/sasm/sasm-2.2-r1.ebuild
new file mode 100644
index 000000000000..7c9c73aab793
--- /dev/null
+++ b/dev-util/sasm/sasm-2.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/Dman95/SASM.git"
+ SRC_URI=""
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Dman95/SASM/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/SASM-${PV}"
+fi
+
+DESCRIPTION="Simple crossplatform IDE for NASM assembly language"
+HOMEPAGE="http://dman95.github.io/SASM/"
+
+LICENSE="GPL-3"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+REPEND="${DEPEND}
+ dev-lang/nasm
+ sys-devel/gdb
+"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+}