summaryrefslogtreecommitdiff
path: root/dev-util/trace-cmd/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /dev-util/trace-cmd/files
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'dev-util/trace-cmd/files')
-rw-r--r--dev-util/trace-cmd/files/trace-cmd-2.5.1-makefile.patch34
-rw-r--r--dev-util/trace-cmd/files/trace-cmd-2.7-soname.patch13
2 files changed, 13 insertions, 34 deletions
diff --git a/dev-util/trace-cmd/files/trace-cmd-2.5.1-makefile.patch b/dev-util/trace-cmd/files/trace-cmd-2.5.1-makefile.patch
deleted file mode 100644
index ec9fb1774a3a..000000000000
--- a/dev-util/trace-cmd/files/trace-cmd-2.5.1-makefile.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 186e245..9127f23 100644
---- a/Makefile
-+++ b/Makefile
-@@ -58,7 +58,7 @@ plugin_dir = $(HOME)/.trace-cmd/plugins
- python_dir = $(HOME)/.trace-cmd/python
- else
- plugin_dir = $(prefix)/$(libdir)/trace-cmd/plugins
--python_dir = $(prefix)/$(libdir)/trace-cmd/python
-+python_dir ?= $(prefix)/$(libdir)/trace-cmd/python
- PLUGIN_DIR = -DPLUGIN_DIR="$(plugin_dir)"
- PYTHON_DIR = -DPYTHON_DIR="$(python_dir)"
- PLUGIN_DIR_SQ = '$(subst ','\'',$(PLUGIN_DIR))'
-@@ -98,8 +98,11 @@ endif # NO_PYTHON
- test-build = $(if $(shell sh -c 'echo "$(1)" | \
- $(CC) -o /dev/null -c -x c - > /dev/null 2>&1 && echo y'), $2)
-
-+ifndef NO_UDIS86
- # have udis86 disassembler library?
--udis86-flags := $(call test-build,\#include <udis86.h>,-DHAVE_UDIS86 -ludis86)
-+udis86-flags := -DHAVE_UDIS86
-+udis86-ldflags := -ludis86
-+endif # NO_UDIS86
-
- define BLK_TC_FLUSH_SOURCE
- #include <linux/blktrace_api.h>
-@@ -242,6 +245,7 @@ endif
- # Append required CFLAGS
- override CFLAGS += $(CONFIG_FLAGS) $(INCLUDES) $(PLUGIN_DIR_SQ)
- override CFLAGS += $(udis86-flags) $(blk-flags)
-+override LDFLAGS += $(udis86-ldflags)
-
- ifeq ($(VERBOSE),1)
- Q =
diff --git a/dev-util/trace-cmd/files/trace-cmd-2.7-soname.patch b/dev-util/trace-cmd/files/trace-cmd-2.7-soname.patch
new file mode 100644
index 000000000000..937f0617a4a4
--- /dev/null
+++ b/dev-util/trace-cmd/files/trace-cmd-2.7-soname.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index a5d2c38..588809e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -308,7 +308,7 @@ do_app_build = \
+
+ do_compile_shared_library = \
+ ($(print_shared_lib_compile) \
+- $(CC) --shared $^ -o $@)
++ $(CC) --shared $^ -Wl,-soname,$@ -o $@)
+
+ do_compile_plugin_obj = \
+ ($(print_plugin_obj_compile) \