summaryrefslogtreecommitdiff
path: root/dev-util/trace-cmd/trace-cmd-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
commit121ed4eec41fbf03e1998d09eede1bf449da63b9 (patch)
treece9341d77d1507f67d4a3a1472da9011b5baa0a8 /dev-util/trace-cmd/trace-cmd-9999.ebuild
parentdd762ff83c330186ee2ede002e08b2f780cddd51 (diff)
gentoo resync : 19.07.2019
Diffstat (limited to 'dev-util/trace-cmd/trace-cmd-9999.ebuild')
-rw-r--r--dev-util/trace-cmd/trace-cmd-9999.ebuild59
1 files changed, 43 insertions, 16 deletions
diff --git a/dev-util/trace-cmd/trace-cmd-9999.ebuild b/dev-util/trace-cmd/trace-cmd-9999.ebuild
index 27b25b7f1212..33ae834f1ac4 100644
--- a/dev-util/trace-cmd/trace-cmd-9999.ebuild
+++ b/dev-util/trace-cmd/trace-cmd-9999.ebuild
@@ -2,9 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=(python2_7)
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
+DISTUTILS_OPTIONAL=1
-inherit linux-info python-single-r1 toolchain-funcs
+inherit linux-info python-r1 toolchain-funcs
DESCRIPTION="User-space front-end for Ftrace"
HOMEPAGE="https://git.kernel.org/cgit/linux/kernel/git/rostedt/trace-cmd.git"
@@ -13,7 +14,7 @@ if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/rostedt/${PN}.git"
inherit git-r3
else
- SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/rostedt/${PN}.git/snapshot/${PN}-v${PV}.tar.gz"
+ SRC_URI="https://git.kernel.org/pub/scm/utils/trace-cmd/trace-cmd.git/snapshot/${PN}-v${PV}.tar.gz"
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${PN}-v${PV}"
fi
@@ -41,13 +42,13 @@ CONFIG_CHECK="
~BLK_DEV_IO_TRACE"
PATCHES=(
- "${FILESDIR}"/trace-cmd-2.7-makefile.patch
- "${FILESDIR}"/trace-cmd-2.7-soname.patch
+ "${FILESDIR}/trace-cmd-2.7-makefile.patch"
+ "${FILESDIR}/trace-cmd-2.8-python-pkgconfig-name.patch"
+ "${FILESDIR}/trace-cmd-2.8-soname.patch"
)
pkg_setup() {
linux-info_pkg_setup
- use python && python-single-r1_pkg_setup
}
src_configure() {
@@ -58,26 +59,52 @@ src_configure() {
"AR=$(tc-getAR)"
$(usex audit '' '' '' 'NO_AUDIT=1')
$(usex udis86 '' '' '' 'NO_UDIS86=1')
+ VERBOSE=1
)
+}
+
+src_compile() {
+ emake "${EMAKE_FLAGS[@]}" NO_PYTHON=1 \
+ trace-cmd libs
if use python; then
- EMAKE_FLAGS+=(
- "PYTHON_VERS=${EPYTHON//python/python-}"
- "python_dir=$(python_get_sitedir)/${PN}"
- )
- else
- EMAKE_FLAGS+=("NO_PYTHON=1")
+ python_copy_sources
+ python_foreach_impl python_compile
fi
-}
-src_compile() {
- emake "${EMAKE_FLAGS[@]}" all_cmd libs
use doc && emake doc
+}
+python_compile() {
+ pushd "${BUILD_DIR}" > /dev/null || die
+ python_is_python3 && eapply "${FILESDIR}/trace-cmd-2.8-python3-warnings.patch"
+
+ emake "${EMAKE_FLAGS[@]}" \
+ PYTHON_VERS="${EPYTHON}" \
+ PYTHON_PKGCONFIG_VERS="${EPYTHON//python/python-}" \
+ python_dir=$(python_get_sitedir)/${PN} \
+ python python-plugin
+
+ popd > /dev/null || die
}
src_install() {
- emake "${EMAKE_FLAGS[@]}" DESTDIR="${D}" V=1 install install_libs
+ emake "${EMAKE_FLAGS[@]}" NO_PYTHON=1 \
+ DESTDIR="${D}" \
+ install install_libs
+
use doc && emake DESTDIR="${D}" install_doc
+ use python && python_foreach_impl python_install
+}
+
+python_install() {
+ pushd "${BUILD_DIR}" > /dev/null || die
+
+ emake "${EMAKE_FLAGS[@]}" DESTDIR="${D}" \
+ PYTHON_VERS="${EPYTHON}" \
+ PYTHON_PKGCONFIG_VERS="${EPYTHON//python/python-}" \
+ python_dir=$(python_get_sitedir)/${PN} \
+ install_python
+ popd > /dev/null || die
}