summaryrefslogtreecommitdiff
path: root/games-action/supermariowar/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /games-action/supermariowar/files
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'games-action/supermariowar/files')
-rw-r--r--games-action/supermariowar/files/supermariowar-2.0_beta1-cmake-add_library-static.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/games-action/supermariowar/files/supermariowar-2.0_beta1-cmake-add_library-static.patch b/games-action/supermariowar/files/supermariowar-2.0_beta1-cmake-add_library-static.patch
new file mode 100644
index 000000000000..2ecc26977598
--- /dev/null
+++ b/games-action/supermariowar/files/supermariowar-2.0_beta1-cmake-add_library-static.patch
@@ -0,0 +1,18 @@
+Fix linking with BUILD_SHARED_LIBS=ON default in EAPI-7
+
+--- a/src/common_netplay/CMakeLists.txt
++++ b/src/common_netplay/CMakeLists.txt
+@@ -1,4 +1,4 @@
+
+ if(NOT NO_NETWORK)
+- add_library(NetplayFiles platform_enet/NetPeerENet.cpp)
++ add_library(NetplayFiles STATIC platform_enet/NetPeerENet.cpp)
+ endif()
+--- a/src/common/CMakeLists.txt
++++ b/src/common/CMakeLists.txt
+@@ -39,4 +39,4 @@
+ list(APPEND COMMON_SRCS src/savepng.cpp)
+ endif()
+
+-add_library(CommonFiles ${COMMON_SRCS})
++add_library(CommonFiles STATIC ${COMMON_SRCS})