summaryrefslogtreecommitdiff
path: root/games-arcade/supertux/supertux-0.6.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /games-arcade/supertux/supertux-0.6.3.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'games-arcade/supertux/supertux-0.6.3.ebuild')
-rw-r--r--games-arcade/supertux/supertux-0.6.3.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/games-arcade/supertux/supertux-0.6.3.ebuild b/games-arcade/supertux/supertux-0.6.3.ebuild
index 0a9fb27d74ef..173ea4e074c1 100644
--- a/games-arcade/supertux/supertux-0.6.3.ebuild
+++ b/games-arcade/supertux/supertux-0.6.3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
#: ${CMAKE_MAKEFILE_GENERATOR:=emake}
-inherit cmake flag-o-matic
+inherit cmake
MY_PV="${PV/_rc/-rc.}"
MY_P="SuperTux-v${MY_PV}-Source"
@@ -12,6 +12,7 @@ MY_P="SuperTux-v${MY_PV}-Source"
DESCRIPTION="A game similar to Super Mario Bros"
HOMEPAGE="https://supertux.org/"
SRC_URI="https://github.com/SuperTux/${PN}/releases/download/v${MY_PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2+ GPL-3+ ZLIB MIT CC-BY-SA-2.0 CC-BY-SA-3.0"
SLOT="0"
@@ -41,16 +42,13 @@ BDEPEND="
virtual/pkgconfig
"
-S="${WORKDIR}/${MY_P}"
-
PATCHES=(
"${FILESDIR}"/${PN}-0.5.0-tinygettext.patch
"${FILESDIR}"/${PN}-0.6.0-{license,icon,obstack}.patch
+ "${FILESDIR}"/${PN}-0.6.3-missing-include.patch
)
src_configure() {
- append-cxxflags -std=c++11
-
local mycmakeargs=(
-DWERROR=OFF
-DINSTALL_SUBDIR_BIN=bin