summaryrefslogtreecommitdiff
path: root/games-util/mcrcon/mcrcon-0.7.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
commitfc2f1018fc323ef2c6572734a9b130427cba76a6 (patch)
treef834bdc9a67923ce75297c09d00d1e7b90791d26 /games-util/mcrcon/mcrcon-0.7.2.ebuild
parent162945d2a91899b637bbb9e163b406350de12906 (diff)
gentoo resync : 03.11.2021
Diffstat (limited to 'games-util/mcrcon/mcrcon-0.7.2.ebuild')
-rw-r--r--games-util/mcrcon/mcrcon-0.7.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/games-util/mcrcon/mcrcon-0.7.2.ebuild b/games-util/mcrcon/mcrcon-0.7.2.ebuild
new file mode 100644
index 000000000000..80b64e933516
--- /dev/null
+++ b/games-util/mcrcon/mcrcon-0.7.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Remote connection client for Minecraft servers"
+HOMEPAGE="https://github.com/Tiiffi/mcrcon"
+SRC_URI="https://github.com/Tiiffi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${LDFLAGS} -std=gnu99 -Wall -Wextra -Wpedantic"
+}
+
+src_install() {
+ emake install PREFIX="${ED}/usr"
+}