summaryrefslogtreecommitdiff
path: root/gnustep-libs/dbuskit/dbuskit-0.1.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-19 23:10:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-19 23:10:29 +0100
commit318828e81fe6707ce5a64e6a59a76d4c0ca709f8 (patch)
treecc4b7818f7960cb193ad2bf7f7defe71adb3ee47 /gnustep-libs/dbuskit/dbuskit-0.1.1-r2.ebuild
parent590c04803f88a968b4a750c0f420eb314e1fe968 (diff)
gentoo auto-resync : 19:09:2023 - 23:10:29
Diffstat (limited to 'gnustep-libs/dbuskit/dbuskit-0.1.1-r2.ebuild')
-rw-r--r--gnustep-libs/dbuskit/dbuskit-0.1.1-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnustep-libs/dbuskit/dbuskit-0.1.1-r2.ebuild b/gnustep-libs/dbuskit/dbuskit-0.1.1-r2.ebuild
new file mode 100644
index 000000000000..841a257ae165
--- /dev/null
+++ b/gnustep-libs/dbuskit/dbuskit-0.1.1-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools gnustep-2
+
+DESCRIPTION="Framework that interfaces Objective-C applications with the D-Bus IPC service"
+HOMEPAGE="https://github.com/gnustep/libs-dbuskit"
+SRC_URI="https://github.com/gnustep/libs-dbuskit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/libs-${P}"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND=">=sys-apps/dbus-1.2.1"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-remove_gc.patch )
+
+src_prepare() {
+ default
+
+ if ! use doc; then
+ # Remove doc target
+ sed -i -e "/SUBPROJECTS/s/Documentation//" GNUmakefile \
+ || die "doc sed failed"
+ fi
+
+ # Bug 410697
+ sed -e "s#ObjectiveC2/runtime.h#ObjectiveC2/objc/runtime.h#" \
+ -i configure.ac || die "ObjectiveC2 runtime sed failed"
+
+ eautoreconf
+}