summaryrefslogtreecommitdiff
path: root/kde-frameworks/kpty/kpty-5.92.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /kde-frameworks/kpty/kpty-5.92.0.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'kde-frameworks/kpty/kpty-5.92.0.ebuild')
-rw-r--r--kde-frameworks/kpty/kpty-5.92.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/kde-frameworks/kpty/kpty-5.92.0.ebuild b/kde-frameworks/kpty/kpty-5.92.0.ebuild
new file mode 100644
index 000000000000..7287577f7e70
--- /dev/null
+++ b/kde-frameworks/kpty/kpty-5.92.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+inherit ecm kde.org
+
+DESCRIPTION="Framework for pseudo terminal devices and running child processes"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ sys-libs/libutempter
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUTEMPTER_EXECUTABLE="${EPREFIX}/usr/sbin/utempter"
+ )
+
+ ecm_src_configure
+}