summaryrefslogtreecommitdiff
path: root/mate-base/mate-common/mate-common-1.26.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /mate-base/mate-common/mate-common-1.26.0.ebuild
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'mate-base/mate-common/mate-common-1.26.0.ebuild')
-rw-r--r--mate-base/mate-common/mate-common-1.26.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/mate-base/mate-common/mate-common-1.26.0.ebuild b/mate-base/mate-common/mate-common-1.26.0.ebuild
new file mode 100644
index 000000000000..2032d986c8a6
--- /dev/null
+++ b/mate-base/mate-common/mate-common-1.26.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit mate-desktop.org
+
+if [[ ${PV} == 9999 ]]; then
+ inherit autotools
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Common files for development of MATE packages"
+LICENSE="GPL-3+"
+SLOT="0"
+
+src_prepare() {
+ default
+ if [[ ${PV} == 9999 ]]; then
+ eautoreconf
+ fi
+}
+
+src_install() {
+ mv doc-build/README README.doc-build \
+ || die "Failed to rename doc-build/README."
+
+ default
+
+ dodoc doc/usage.txt
+}