summaryrefslogtreecommitdiff
path: root/media-sound/sc2mpd/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /media-sound/sc2mpd/files
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'media-sound/sc2mpd/files')
-rw-r--r--media-sound/sc2mpd/files/ohnet.makefile.patch35
-rw-r--r--media-sound/sc2mpd/files/ohnet.optionparser.patch12
-rw-r--r--media-sound/sc2mpd/files/ohnetgenerated.commonmk.patch24
-rw-r--r--media-sound/sc2mpd/files/ohnetgenerated.makefile.patch30
4 files changed, 101 insertions, 0 deletions
diff --git a/media-sound/sc2mpd/files/ohnet.makefile.patch b/media-sound/sc2mpd/files/ohnet.makefile.patch
new file mode 100644
index 000000000000..29a29bcc9bb5
--- /dev/null
+++ b/media-sound/sc2mpd/files/ohnet.makefile.patch
@@ -0,0 +1,35 @@
+diff --git a/Makefile b/Makefile
+index 29f2d6a..038b05e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -82,12 +82,19 @@ else
+ ifneq (,$(findstring arm,$(gcc_machine)))
+ ifneq (,$(findstring linux-gnueabihf,$(gcc_machine)))
+ detected_openhome_architecture = armhf
++ else ifneq (,$(findstring armv7hl,$(gcc_machine)))
++ # cubox: armv7hl-redhat-linux-gnueabi
++ detected_openhome_architecture = armhf
+ else ifeq (${detected_openhome_system},Qnap)
+ detected_openhome_architecture = x19
+ else
+ detected_openhome_architecture = armel
+ endif
+ endif
++ ifneq (,$(findstring aarch64,$(gcc_machine)))
++ # odroid64: aarch64-linux-gnu
++ detected_openhome_architecture = arm64
++ endif
+ ifneq (,$(findstring i686,$(gcc_machine)))
+ detected_openhome_architecture = x86
+ endif
+@@ -375,6 +382,10 @@ mkdir = mkdir -p
+ rmdir = rm -rf
+ uset4 = no
+
++# This avoids errors in Generated/Devices.mak (they apparently have no
++# consequences anyway because we use make native_only=yes)
++t4 = echo
++
+ ifeq ($(managed_only), yes)
+ build_targets_base = make_obj_dir ohNet.net.dll CpProxyDotNetAssemblies DvDeviceDotNetAssemblies
+ else
diff --git a/media-sound/sc2mpd/files/ohnet.optionparser.patch b/media-sound/sc2mpd/files/ohnet.optionparser.patch
new file mode 100644
index 000000000000..a31657684271
--- /dev/null
+++ b/media-sound/sc2mpd/files/ohnet.optionparser.patch
@@ -0,0 +1,12 @@
+diff --git a/OpenHome/TestFramework/OptionParser.cpp b/OpenHome/TestFramework/OptionParser.cpp
+index fe90233..644fc0b 100644
+--- a/OpenHome/TestFramework/OptionParser.cpp
++++ b/OpenHome/TestFramework/OptionParser.cpp
+@@ -282,6 +282,6 @@ void OptionParser::SetUsage(const TChar* aUsage)
+ {
+ delete iUsage;
+ iUsage = NULL;
+- iUsage = new TChar[strlen(iUsage)];
++ iUsage = new TChar[strlen(aUsage)];
+ (void)strcpy(iUsage, aUsage);
+ }
diff --git a/media-sound/sc2mpd/files/ohnetgenerated.commonmk.patch b/media-sound/sc2mpd/files/ohnetgenerated.commonmk.patch
new file mode 100644
index 000000000000..a4f28f9a7009
--- /dev/null
+++ b/media-sound/sc2mpd/files/ohnetgenerated.commonmk.patch
@@ -0,0 +1,24 @@
+diff -u ./Common.mak ../../openhome/ohNetGenerated/Common.mak
+--- ./Common.mak 2017-09-19 10:51:13.000000000 +0200
++++ ./Common.mak 2017-09-19 13:21:25.984071432 +0200
+@@ -17,20 +17,6 @@
+ $(objdir)ohnet-generated.jar : CpProxyJavaClasses DvDeviceJavaClasses
+ $(jar) $(jarflags) $(objdir)ohnet-generated.jar -C $(objdir) org
+
+-Generated$(dirsep)GenerateSourceFiles.mak : $(tt) OpenHome$(dirsep)Net$(dirsep)Service$(dirsep)Services.xml OpenHome/Net/T4/Templates/UpnpMakeT4.tt
+- $(mkdir) Generated
+- $(t4) -o Generated$(dirsep)GenerateSourceFiles.mak OpenHome/Net/T4/Templates/UpnpMakeT4.tt -a xml:OpenHome/Net/Service/Services.xml
+- @echo Attention: a makefile has been re-generated.
+-
+-Generated$(dirsep)Proxies.mak : $(tt) OpenHome$(dirsep)Net$(dirsep)Service$(dirsep)Services.xml OpenHome/Net/T4/Templates/CpUpnpMakeProxies.tt
+- $(mkdir) Generated
+- $(t4) -o Generated$(dirsep)Proxies.mak OpenHome/Net/T4/Templates/CpUpnpMakeProxies.tt -a xml:OpenHome/Net/Service/Services.xml
+- @echo Attention: a makefile has been re-generated.
+-
+-Generated$(dirsep)Devices.mak : $(tt) OpenHome$(dirsep)Net$(dirsep)Service$(dirsep)Services.xml OpenHome/Net/T4/Templates/DvUpnpMakeDevices.tt
+- $(mkdir) Generated
+- $(t4) -o Generated$(dirsep)Devices.mak OpenHome/Net/T4/Templates/DvUpnpMakeDevices.tt -a xml:OpenHome/Net/Service/Services.xml
+- @echo Attention: a makefile has been re-generated.
+
+ native_targets = make_obj_dir copy_build_includes proxies devices
+
diff --git a/media-sound/sc2mpd/files/ohnetgenerated.makefile.patch b/media-sound/sc2mpd/files/ohnetgenerated.makefile.patch
new file mode 100644
index 000000000000..d320cefbd473
--- /dev/null
+++ b/media-sound/sc2mpd/files/ohnetgenerated.makefile.patch
@@ -0,0 +1,30 @@
+diff --git a/Makefile b/Makefile
+index bf7a1ba..49bffaf 100644
+--- a/Makefile
++++ b/Makefile
+@@ -70,14 +70,17 @@ else
+ else ifneq (,$(findstring linux,$(gcc_machine)))
+ detected_openhome_system = Linux
+ endif
+- ifeq ($(gcc_machine),arm-none-linux-gnueabi)
+- detected_openhome_architecture = armel
+- endif
+- ifeq ($(gcc_machine),arm-linux-gnueabi)
+- detected_openhome_architecture = armel
+- endif
+- ifeq ($(gcc_machine),arm-linux-gnueabihf)
+- detected_openhome_architecture = armhf
++ ifneq (,$(findstring arm,$(gcc_machine)))
++ ifneq (,$(findstring linux-gnueabihf,$(gcc_machine)))
++ detected_openhome_architecture = armhf
++ else ifneq (,$(findstring armv7hl,$(gcc_machine)))
++ # cubox: armv7hl-redhat-linux-gnueabi
++ detected_openhome_architecture = armhf
++ else ifeq (${detected_openhome_system},Qnap)
++ detected_openhome_architecture = x19
++ else
++ detected_openhome_architecture = armel
++ endif
+ endif
+ ifneq (,$(findstring i686,$(gcc_machine)))
+ detected_openhome_architecture = x86