summaryrefslogtreecommitdiff
path: root/net-irc/scrollz/scrollz-2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
commit09351e78166b5e864197c4456ebae3f89dd0bed9 (patch)
tree41a96399f56ed3aa399006871bfce4430db84aa2 /net-irc/scrollz/scrollz-2.3.ebuild
parentc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (diff)
gentoo resync : 22.01.2019
Diffstat (limited to 'net-irc/scrollz/scrollz-2.3.ebuild')
-rw-r--r--net-irc/scrollz/scrollz-2.3.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/net-irc/scrollz/scrollz-2.3.ebuild b/net-irc/scrollz/scrollz-2.3.ebuild
new file mode 100644
index 000000000000..91c290474e36
--- /dev/null
+++ b/net-irc/scrollz/scrollz-2.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+MY_P="ScrollZ-${PV}"
+
+DESCRIPTION="Advanced IRC client based on ircII"
+HOMEPAGE="http://www.scrollz.info/"
+SRC_URI="http://www.scrollz.info/download/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+IUSE="gmp gnutls ipv6 socks5 ssl"
+REQUIRED_USE="gnutls? ( ssl )"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ gmp? ( dev-libs/gmp:0= )
+ ssl? (
+ gnutls? ( net-libs/gnutls:0= )
+ !gnutls? ( dev-libs/openssl:0= )
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/ScrollZ-${MY_P}"
+
+src_configure() {
+ local _myssl
+
+ if use ssl; then
+ if use gnutls; then
+ _myssl="--with-ssl"
+ else
+ _myssl="--with-openssl"
+ fi
+ fi
+
+ tc-export CC #397441, ancient autoconf
+ econf \
+ --with-default-server="irc.gentoo.org" \
+ $(use_with socks5) \
+ $(use_enable ipv6) \
+ --enable-regexp \
+ $(use_enable gmp fish) \
+ ${_myssl}
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ mandir="${EPREFIX}/usr/share/man/man1" \
+ install
+
+ dodoc ChangeLog* NEWS README* todo
+}