summaryrefslogtreecommitdiff
path: root/net-libs/libiio/libiio-0.21.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /net-libs/libiio/libiio-0.21.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'net-libs/libiio/libiio-0.21.ebuild')
-rw-r--r--net-libs/libiio/libiio-0.21.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-libs/libiio/libiio-0.21.ebuild b/net-libs/libiio/libiio-0.21.ebuild
new file mode 100644
index 000000000000..66f1603cbe68
--- /dev/null
+++ b/net-libs/libiio/libiio-0.21.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Library for interfacing with IIO devices"
+HOMEPAGE="https://github.com/analogdevicesinc/libiio"
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/analogdevicesinc/libiio"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/analogdevicesinc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+IUSE="+aio +zeroconf"
+
+RDEPEND="dev-libs/libxml2:=
+ virtual/libusb:1=
+ aio? ( dev-libs/libaio )
+ zeroconf? ( net-dns/avahi )"
+DEPEND="${RDEPEND}"