summaryrefslogtreecommitdiff
path: root/net-mail/autorespond/autorespond-2.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-mail/autorespond/autorespond-2.0.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-mail/autorespond/autorespond-2.0.5.ebuild')
-rw-r--r--net-mail/autorespond/autorespond-2.0.5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-mail/autorespond/autorespond-2.0.5.ebuild b/net-mail/autorespond/autorespond-2.0.5.ebuild
new file mode 100644
index 000000000000..f8b0e5f0413a
--- /dev/null
+++ b/net-mail/autorespond/autorespond-2.0.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils
+
+DESCRIPTION="Autoresponder add on package for qmailadmin"
+HOMEPAGE="http://inter7.com/devel/"
+SRC_URI="http://inter7.com/devel/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/qmail"
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-no-include-bounce.patch
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install () {
+ into /var/qmail
+ dobin autorespond || die "dobin failed"
+ into /usr
+ dodoc README help_message qmail-auto #ChangeLog
+ doman *.1
+}
+
+pkg_postinst() {
+ ewarn "Please note that original messages are now NOT included with bounces"
+ ewarn "by default. Use the flag per the help output if you want them."
+}