summaryrefslogtreecommitdiff
path: root/net-mail/mlmmj/mlmmj-1.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-21 18:00:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-21 18:00:10 +0100
commit265dbe5dbc14c199299496c6db8fce3f76647015 (patch)
treeab18b5617d138f6684566b619405090989d55a2c /net-mail/mlmmj/mlmmj-1.3.0.ebuild
parent586819755b4dbfdffdc8a725ab7c0f86095b8489 (diff)
gentoo resync : 21.09.2018
Diffstat (limited to 'net-mail/mlmmj/mlmmj-1.3.0.ebuild')
-rw-r--r--net-mail/mlmmj/mlmmj-1.3.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-mail/mlmmj/mlmmj-1.3.0.ebuild b/net-mail/mlmmj/mlmmj-1.3.0.ebuild
new file mode 100644
index 000000000000..66a6bc8a1e10
--- /dev/null
+++ b/net-mail/mlmmj/mlmmj-1.3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PV="${PV/_rc/-RC}"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="Mailing list managing made joyful"
+HOMEPAGE="http://mlmmj.org/"
+SRC_URI="http://mlmmj.org/releases/${MY_P}.tar.bz2"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+DEPEND="virtual/mta"
+S="${WORKDIR}/${MY_P}"
+
+DOCS="AUTHORS ChangeLog FAQ README* TODO TUNABLES UPGRADE"
+PATCHES=(
+ "${FILESDIR}"/mlmmj-1.2.19.0-listcontrol-customheaders.patch
+)
+
+src_configure() {
+ econf --enable-receive-strip
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/mlmmj/texts
+ doins listtexts/*
+
+ insinto /usr/share/mlmmj
+ doins -r contrib/web/*
+}
+
+pkg_postinst() {
+ elog "mlmmj comes with serveral webinterfaces:"
+ elog "- One for user subscribing/unsubscribing"
+ elog "- One for admin tasks"
+ elog "both available in a php and perl module."
+ elog "For more info have a look in /usr/share/mlmmj"
+}