summaryrefslogtreecommitdiff
path: root/net-misc/etherdfs/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /net-misc/etherdfs/files
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'net-misc/etherdfs/files')
-rw-r--r--net-misc/etherdfs/files/etherdfs-20180203-makefile.patch14
-rw-r--r--net-misc/etherdfs/files/etherdfs.confd9
-rw-r--r--net-misc/etherdfs/files/etherdfs.initd11
-rw-r--r--net-misc/etherdfs/files/etherdfs.service10
4 files changed, 44 insertions, 0 deletions
diff --git a/net-misc/etherdfs/files/etherdfs-20180203-makefile.patch b/net-misc/etherdfs/files/etherdfs-20180203-makefile.patch
new file mode 100644
index 000000000000..1cbf51cb65fe
--- /dev/null
+++ b/net-misc/etherdfs/files/etherdfs-20180203-makefile.patch
@@ -0,0 +1,14 @@
+--- a/Makefile 2018-02-03 21:21:51.518384435 +0100
++++ b/Makefile 2019-12-27 01:23:37.030323263 +0100
+@@ -5,9 +5,9 @@
+ # Copyright (C) 2017, 2018 Mateusz Viste
+ #
+
+-CFLAGS = -O2 -Wall -std=gnu89 -pedantic -Wextra -s -Wno-long-long -Wno-variadic-macros -Wformat-security -D_FORTIFY_SOURCE=1
++CFLAGS += -Wall -std=gnu89 -pedantic -Wextra -Wno-long-long -Wno-variadic-macros -Wformat-security -D_FORTIFY_SOURCE=1
+
+-CC = gcc
++CC ?= gcc
+
+ ethersrv-linux: ethersrv-linux.c fs.c fs.h lock.c lock.h debug.h
+ $(CC) ethersrv-linux.c fs.c lock.c -o ethersrv-linux $(CFLAGS)
diff --git a/net-misc/etherdfs/files/etherdfs.confd b/net-misc/etherdfs/files/etherdfs.confd
new file mode 100644
index 000000000000..1a5a116e8412
--- /dev/null
+++ b/net-misc/etherdfs/files/etherdfs.confd
@@ -0,0 +1,9 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Network interface, which should be used for serving mapped drives
+INTERFACE="lo"
+
+# Storage directories, which are being mapped and served to the client.
+# Multiple directories can be specified, by whitespace separated.
+STORAGEDIR="/tmp"
diff --git a/net-misc/etherdfs/files/etherdfs.initd b/net-misc/etherdfs/files/etherdfs.initd
new file mode 100644
index 000000000000..dd3b0b27d5ac
--- /dev/null
+++ b/net-misc/etherdfs/files/etherdfs.initd
@@ -0,0 +1,11 @@
+#!/sbin/openrc-run
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+name="etherdfs daemon"
+command="/usr/bin/ethersrv-linux"
+command_args="${INTERFACE} ${STORAGEDIR}"
+
+depend() {
+ need net
+}
diff --git a/net-misc/etherdfs/files/etherdfs.service b/net-misc/etherdfs/files/etherdfs.service
new file mode 100644
index 000000000000..d5a6ed474a6a
--- /dev/null
+++ b/net-misc/etherdfs/files/etherdfs.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=etherdfs daemon
+After=network-online.target
+
+[Service]
+EnvironmentFile=/etc/conf.d/etherdfs
+ExecStart=/usr/bin/ethersrv-linux ${INTERFACE} ${STORAGEDIR}
+
+[Install]
+WantedBy=multi-user.target