summaryrefslogtreecommitdiff
path: root/net-vpn/openconnect/openconnect-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /net-vpn/openconnect/openconnect-9999.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'net-vpn/openconnect/openconnect-9999.ebuild')
-rw-r--r--net-vpn/openconnect/openconnect-9999.ebuild85
1 files changed, 33 insertions, 52 deletions
diff --git a/net-vpn/openconnect/openconnect-9999.ebuild b/net-vpn/openconnect/openconnect-9999.ebuild
index 16e3dcc31c8a..4442fa5bf4d3 100644
--- a/net-vpn/openconnect/openconnect-9999.ebuild
+++ b/net-vpn/openconnect/openconnect-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 2011-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python{3_6,3_7} )
PYTHON_REQ_USE="xml"
-inherit eutils linux-info python-any-r1 readme.gentoo-r1
+inherit linux-info python-any-r1
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://gitlab.com/openconnect/openconnect.git"
@@ -15,7 +15,7 @@ else
ARCHIVE_URI="ftp://ftp.infradead.org/pub/${PN}/${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
fi
-VPNC_VER=20190611
+VPNC_VER=20200226
SRC_URI="${ARCHIVE_URI}
ftp://ftp.infradead.org/pub/vpnc-scripts/vpnc-scripts-${VPNC_VER}.tar.gz"
@@ -24,14 +24,13 @@ HOMEPAGE="http://www.infradead.org/openconnect.html"
LICENSE="LGPL-2.1 GPL-2"
SLOT="0/5"
-IUSE="doc +gnutls gssapi libproxy libressl lz4 nls smartcard static-libs stoken"
+IUSE="doc +gnutls gssapi libproxy lz4 nls smartcard static-libs stoken"
DEPEND="
dev-libs/libxml2
sys-libs/zlib
!gnutls? (
- !libressl? ( >=dev-libs/openssl-1.0.1h:0=[static-libs?] )
- libressl? ( dev-libs/libressl:0=[static-libs?] )
+ >=dev-libs/openssl-1.0.1h:0=[static-libs?]
)
gnutls? (
app-crypt/trousers
@@ -44,14 +43,16 @@ DEPEND="
lz4? ( app-arch/lz4:= )
nls? ( virtual/libintl )
smartcard? ( sys-apps/pcsc-lite:0= )
- stoken? ( app-crypt/stoken )"
+ stoken? ( app-crypt/stoken )
+"
RDEPEND="${DEPEND}
sys-apps/iproute2
- !<sys-apps/openrc-0.13"
+"
BDEPEND="
virtual/pkgconfig
doc? ( ${PYTHON_DEPS} sys-apps/groff )
- nls? ( sys-devel/gettext )"
+ nls? ( sys-devel/gettext )
+"
CONFIG_CHECK="~TUN"
@@ -88,10 +89,9 @@ src_configure() {
addwrite /run/netns
local myconf=(
- --with-vpnc-script="${EPREFIX}/etc/openconnect/openconnect.sh"
- --without-openssl-version-check
- $(use_enable static-libs static)
+ --disable-dsa-tests
$(use_enable nls)
+ $(use_enable static-libs static)
$(use_with !gnutls openssl)
$(use_with gnutls)
$(use_with libproxy)
@@ -99,62 +99,43 @@ src_configure() {
$(use_with gssapi)
$(use_with smartcard libpcsclite)
$(use_with stoken)
+ --with-vpnc-script="${EPREFIX}/etc/openconnect/openconnect.sh"
--without-java
)
econf "${myconf[@]}"
}
-DOC_CONTENTS="The init script for openconnect supports multiple vpn tunnels.
-
-You need to create a symbolic link to /etc/init.d/openconnect in /etc/init.d
-instead of calling it directly:
-
-ln -s /etc/init.d/openconnect /etc/init.d/openconnect.vpn0
-
-You can then start the vpn tunnel like this:
-
-/etc/init.d/openconnect.vpn0 start
-
-If you would like to run preup, postup, predown, and/or postdown scripts,
-You need to create a directory in /etc/openconnect with the name of the vpn:
-
-mkdir /etc/openconnect/vpn0
-
-Then add executable shell files:
-
-mkdir /etc/openconnect/vpn0
-cd /etc/openconnect/vpn0
-echo '#!/bin/sh' > preup.sh
-cp preup.sh predown.sh
-cp preup.sh postup.sh
-cp preup.sh postdown.sh
-chmod 755 /etc/openconnect/vpn0/*
-"
+src_test() {
+ local charset
+ for charset in UTF-8 ISO8859-2; do
+ if [[ $(LC_ALL=cs_CZ.${charset} locale charmap 2>/dev/null) != ${charset} ]]; then
+ # If we don't have valid cs_CZ locale data, auth-nonascii will fail.
+ # Force a test skip by exiting with status 77.
+ sed -i -e '2i exit 77' tests/auth-nonascii || die
+ break
+ fi
+ done
+ default
+}
src_install() {
default
+ find "${ED}" -name '*.la' -delete || die
+
+ dodoc "${FILESDIR}"/README.OpenRC.txt
+
newinitd "${FILESDIR}"/openconnect.init.in-r4 openconnect
- dodir /etc/openconnect
insinto /etc/openconnect
+
newconfd "${FILESDIR}"/openconnect.conf.in openconnect
+
exeinto /etc/openconnect
newexe "${WORKDIR}"/vpnc-scripts-${VPNC_VER}/vpnc-script openconnect.sh
+
insinto /etc/logrotate.d
newins "${FILESDIR}"/openconnect.logrotate openconnect
- keepdir /var/log/openconnect
-
- find "${ED}" -name '*.la' -delete || die
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog
- elog "You may want to consider installing the following optional packages."
- optfeature "resolvconf support" virtual/resolvconf
- fi
+ keepdir /var/log/openconnect
}